KB-1550 'Patch not available' when adding objects to a patch

Symptoms

The following error is seen when trying to add objects to a patch:

Patch Not Available. Your patch cannot be reached at this time. Check that the data server is running. As a workaround, add your objects to an application and export the full application package.

The following error is also seen in the application server logs:

16:29:55,598 INFO  [stdout] (ServerService Thread Pool -- 83) 2018-04-04 16:29:55,598 [ServerService Thread Pool -- 83] ERROR com.appiancorp.applicationpatch.PatchSchemaSpringContextListener - APNX-1-4506-001 - Failed to connect to data server. The ability to store and retrieve application patches will not be available until the connection is reestablished. Check the status of the data server.

Cause

The Appian data server is not running or is not available. 

Action

To correct this issue, perform the following:

  1. Check the status of the data server by executing <APPIAN_HOME>/data-server/bin/status.sh (status.bat on Windows). 
  2. If the following output is seen, start the data server by executing <APPIAN_HOME>/data-server/bin/start.sh (start.bat on Windows)
0 [main] INFO com.appian.data.TopologyFactory - Loading topology C:\Appian_18.1\data-server\bin\..\conf\appian-topology.xml
461 [main] WARN com.appian.data.server.config.CustomPropertiesConfiguration - Failed to load configuration file custom.properties. Default settings will be used. Cause: null
3494 [main] ERROR com.appian.data.server.CheckWatchdog - Watchdog on localhost:5400 is either down or unable to respond: java.net.ConnectException: Connection refused: connect

Once the data server is started up, objects can be added to patches.

If this issue is experienced in an Appian Cloud environment, please notify Appian Support via a case who will rectify the issue.

Affected Versions

This article applies to Appian 18.1.

Last Reviewed: April 2018

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