KB-1549 Incorrect task ID shown on task escalation e-mails

Symptoms

The task ID shown in a task escalation e-mail does not match the task ID of the task the escalation is referring to.

Cause

The Appian engines are returning an erroneous ID when queried for the Task ID. A request to return the correct ID for this query has been logged to the Appian product team as AN-35324.

Action

The correct ID can be retrieved by using the Get Process Task ID Shared Component.

The task escalation message can be edited in the impacted task's Escalations tab in the Appian Process Modeler. In order to display the correct task ID in the escalation e-mail message, replace all references to the tp!id parameter in the message with calls to the getprocesstaskid() function provided by the Shared Component.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: April 2018

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