KB-1590 Database connection pool maxes out for Oracle data sources configured in the Admin Console

This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Symptoms

For an Oracle data source configured in the Admin Console, there is a notable increase in the number of used connections. Eventually, the connection pool maxes out, preventing any new queries from being executed against that data source.

Cause

There is an issue in the logger responsible for logging data source metrics for data sources defined through the Admin Console, resulting in a connection leak.

This issue has been resolved via AN-105369 in the following hotfixes/versions:

Action

Apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian. 

Workaround

  1. As the Appian user, open the appian_log4j.properties file located in <APPIAN_HOME>/ear/suite.ear/resources/.
  2. Set the value of log4j.logger.com.appian.data-metrics.data_sources from INFO to FATAL. It should look like this: log4j.logger.com.appian.data-metrics.data_sources=FATAL, DATA_SOURCES_METRICS
  3. Restart application server to clear out the inactive sessions.

Affected Versions

This article applies to Appian 17.4 and 18.1.

Last Reviewed: May 2018

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