KB-1663 Basic users are unable to see content in Tempo and receive errors when navigating to Profile and Settings

Symptoms

     1. Basic users are unable to see content in Tempo. The following is a screenshot that illustrates this behavior:

    2. In the application server log, the following error is thrown:


INFO [stdout] (ajp-/0.0.0.0:8009-8) Caused by: PrivilegeException[null=>null]: User Does Not Have Rights to Perform this Operation

    3. When navigating to the user's Profile, an error pop-up appears with the following text:


An error was encountered while processing your request. Please try again.

    4. When navigating to the user's Settings page, the following pink box error appears:

Cause

This issue occurs under the following conditions:

  1. The User pictures/User Covers folder is missing from the Default Community.
  2. Basic users do not have viewer rights on this folder.

Action

For Appian version 17.4 and earlier

First, verify that the User Pictures folder is present in the Default Community. This KB article details how to determine the presence of the folder and how to retrieve it.

Then, verify the security on this folder:

  1. Log in as an Administrator.
  2. Navigate to Runtime Data.
  3. Select Documents and expend the Communities list.
  4. Click on Default Community and then System Knowledge Center.
  5. Click on the User Pictures checkbox and then on Security.
  6. Check the box "Inherit security from parent.".

For Appian version 18.1 and later

Verify that the group All Users has the viewer permission on the User Covers folder:

  1. Log in as an Administrator.
  2. Navigate to Appian Designer.
  3. On the left search bar, search for: User Covers.
  4. Click on the User Covers checkbox and then on Security.
  5. Verify that Default (All Other Users) or the group All User has the Viewer permission level.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: August 2018

Related
Recommended