Cannot clean up locked type when importing application

I am trying to import an application from a 16.1 environment to a 16.2 environment. But I am getting an error about locked CDT.

"A data type could not be updated because it or one of its dependents is currently being updated somewhere else in the system. Please try again later. Details: Invalid Type: Type Error: Cannot clean up locked type - {urn:cdt:isg}ISG_REIMBURSABLE_CHARGE_DETAILS"

Is there a known problem and workaround for exporting and importing from 16.1 to 16.2 version?

Thanks
Nikhil

OriginalPostID-211511

OriginalPostID-211511

  • I suggest publish the datastores again and check datastores are setup correctly
  • @Nikhil, can you try going to the gear menu in the top-right corner of the CDT editor and select "Check Outdated Dependents" when you update definition of CDT in GUI or importing a new CDT. If there are any dependents, then "Update All" button will be displayed which will update all the dependents.
  • @Nikhil - Was anyone else trying to import do update that datatype at the time you were trying to import? Can you please try importing again one hour after when you saw this error.

    #DataTypeEvolution #DTE
  • * trying to import or update ...
  • No luck. I tried after few hours as well. The target server is a new server and has no such application.
    I also tried just importing an application with CDTs and Datastore and then importing the whole application, but that also fails with same error.
  • I tried importing the same package on another 16.1 environment there I don't see this issue.
    The issue occurred only when I tried importing it on a 16.2 environment.
  • Is it possible for you to share the application with us so we can try to reproduce and troubleshoot the problem. You can email it to me directly.
  • I tried importing the application on an another 16.2 system and there I was able to import. Seems it could have been an issue with the earlier environment.
  • It shouldn't have happened in any environment if it was properly upgraded. If it happens again in any environment then please let us know and provide us the application that caused the problem so we can troubleshoot it.
  • Hi I did get the same problem when i tried to deploy one of my application into 16.2 from 7.11 . Any pointers on how to resolve this?
  • Was it a blank 16.2 environment? Can you reproduce it consistently? Can you please share the application that contains the data type that is giving this error. You can email it to me or open a support case and attach it with the ticket.
  • This is a new environment with 2 or 3 new applications which were imported successfully. When we tried to move an another application we are facing this issue. @Zubair I have send you the package in email. Can u please give me Ur email id.
  • Hi All - was there any resolution to this error? Our server became temporarily bogged down in the middle of uploading a new version of a CDT, and now we are receiving the same error message. The environment is not new, and was working fine beforehand. We have had no issue versioning other CDTs since then, but are still unable for the one in question.
  • If you can please provide some details of how you got the error then it will help us find out where the error is and how to fix it. Were you importing an application when you got the error or just trying to update a CDT through Data Type Designer? Any chance that anyone else was updating that CDT at the same time? Did the application include other data types? Does the data type that errored out have other dependent data types or (nested) precedent data types? Do you still get the error if you try to import it again after one hour?
  • Thanks for the response, Zubair - here are the steps which caused the error to occur:
    1. Download [OPA_Supplier] CDT
    2. Update XSD file to add new field
    3. Navigate to designer interface and upload new version of [Supplier] CDT
    - After upload, but during update, I was unexpectedly logged out of Appian.
    - The CDT was not being uploaded by another user at the same time.
    4. After logging back in, the [OPA_Supplier] CDT is no longer available in the list of CDTs.
    5. In attempting to upload the XSD again, I received the following error message:
    "A data type could not be updated because it or one of its dependents is currently being updated somewhere else in the system. Please try again later. Details: Invalid Type: Type Error: Cannot clean up locked type - {urn:com:appian:types:opa}OPA_Supplier"
    - The CDT only has primitive data fields and no nested CDTs.

    We have tried uploading through both /design and /designer portals, logging out and in, uploading with a different user, uploading it within an application, and even restarting the Appian server, but to no avail. It has been > 2 hours since this occurred, and we are running v16.2.

 Discussion posts and replies are publicly visible