SOAP Service call Issue


I am currently trying to make SOAP call to Oracle Right Now(ORN) Enterprise. ORN provides WSDL however I was not able to connect to the WSDL via Web Service smart node, getting 'An error occurred while processing the WSDL. It may not be a valid WSDL 1.1 document. (APNX-1-4041-002)'. tried with third party SOAP test tool and it worked. I am guessing the WSDL is currently not supported by Appian.

Is there an another way to make SOAP call other than Web service smart node?

I was looking into 'Send HTTP Request Plug-in' plug in. The plug in description says it supports to send SOAP XML to a Web Service but didn't provide further instructions. 

If someone can provide more high level details implementation direction or any other approach that I can try, I would really appreciated.

FYI, the following is the example SOAP XML provided ORN for the operation I want to use.

<soapenv:Envelope xmlns:soapenv=''>
    <soapenv:Header xmlns:rnm=''>
        <wsse:Security soapenv:mustUnderstand="false"
                <wsse:Password wsse:Type="
                            <rnb:ID id="1"/>
                    <rno:Subject>Overheating of the device</rno:Subject>
                        <rno:ThreadList action='add'>
                                <rnb:ID id='2'/>
                            <rno:Text>Thank you for reaching out!</rno:Text>
Parents Reply
  • Hi

    You can usually use the HTTP Request route for WSDL's that Appian can't handle. I have done this a few times when the WSDL contained types that Appian did not like.

    The easiest way to go about this is to load your WSDL into SOAPUI or another application meant for testing services. You can pull out the raw XML request body from SOAPUI and throw that into the body input of the Send HTTP Request plug-in.

 Discussion posts and replies are publicly visible