Start Form does not show while debugging...?


I have a process with a start node and a start form (for user inputs) in it.

It takes some inputs and processes them later.

If I start the process via tempo as an action I get presented the start form, can fill in some values and then after submit the process continues as expected.

If I start the same process in the process editor for debugging it skips the start form and the user input and is instantely in the next step, missing all the input from the start form.

What am I missing here?


  Discussion posts and replies are publicly visible

  • I've just tried this out to refresh my memory...and I do get the Start Form displayed as a pre--cursor to the process being started., so I'm not entirely sure why you're not getting the Start Form. One possibility (unlikely, but I'll mention it anyway)...starting a process model in debug mode will run the latest saved version of the model...but from Tempo it'll run the last saved-and-published if you've removed the Start Form and only saved it, you'll get a different experience between Tempo and debug mode (this sounds unlikely given what you've said, but that would be one scenario that would cause the two different behaviours). Otherwise I'm at a loss to explain this.

  • Thx for your effort.

    I rechecked, saved & published and tried it from the process editor with debugging....and the process still jumps to a later step, leaving the start form out.

    I tried via the tempo action and it works fine.

    Something is still wrong here....

    A checkbox somewhere?

    A rights issue ? (I am member of Admin, All_User and Manager Group. Process securitiy is set to Admins/Admin rights and All_user/Viewer Rights; The start node does not seem to have an assignment tab. Later task is assigned to manager group. )

  • Should just look like this:

    When I start the process in debug mode I get a pop-up form that displays the Interface configured as the Start Form:

    Is there something in your browser settings preventing the pop-up?

  • Hmmm I dont thnk so.

    a) I work in this environment for three weeks now and did not have any popup issues

    b.) usually the browser informs me if a popup was blocked and i can toggle it, if something like this occurs

    c.) The other nodes work fine. I sure have to right click and select "View Form", but it works.

    d.) Even if there is a popup blocked or not shown, shouldnt the process stop anyway if the (hidden) form is not submitted???

    Dont think it has anything to do with it...

  • 0
    A Score Level 1
    in reply to aveldena

    Well. Unfortunately it seems like it is indeed some kind of brwoser problem.

    I am running FF 79.0 right now, which is the latest version.

    I have the pop up problem, wether I have the option for "allow pop ups" in FF enabled, disabled or configured with exception rules to sites.

    Suprisingly enough a friend of mine uses the same browser and does not have the issue.

    But a test in Chrome showed, that the form pops up.


    I still do not understand, why the process on the engine continues wether or not the start form is completed or not.

    When the form is not hsown it cannot be submitted , can it?? Why should then the process advance.

    Expected behaviour would be the process idles in the start node , not showing the form and waits for the logged in user to figure out where his bleeping window is... :/

  • Well, that is very strange! I would agree, if the pop-up is being made invisible or not successful you'd expect the process instance to hang, waiting for some event...I just downloaded FF (v 79.0)...and it initially blocked pop-ups, but when I allowed works just fine...must be something specific to your installation...

  • I had a similar problem. My browser language was set to "English (GB)".

    • From "Appian Process Modeler"


    • Select "Properties".


    • Select "Process Start Form".


    • Choose the "English (GB)" tab.


    • Select the "Enable this language" check box.


    • Select the interface and select "Yes" to the "Create Process Parameters" prompt.


    • Select "File...Save and Publish".


    • Select "File...Start Process for Debugging".

    This works if I blocked pop-ups or not, so that may be a red herring.

    I hope this helps.



  • Changing/enabling the form language to EnglishGB resolved this for me! Thanks

  • Thanks  I was having the same issue was not able to figure it out thanks