SFTP Smart Services - Receive Files In Folder Over FTP smart service downloads an empty file or corrupted file

We've been using SFTP Smart Services to download document (XLSX) from FTP location. We tried two smart services available.

1) Receive File Over FTP: This smart service always ends up giving error message as FILE_NOT_FOUND. Even though, all parameters are correct.

2) Retrieve Files In Folder Over FTP: This smart service downloads documents (XLSX) to Appian but when excel is opened, it is empty. We manually checked file by logging at FTP location, we could open a file from there. Also note that files are stored in binary format at FTP location. Please let us know, if there is any other way to download file and open it successfully.

We use following folder file path to retrieve documents. All documents from FTP get downloaded to Appian but when we tried to open them we get a message from excel to recover document. How do we suppress this warning by Excel? These documents are not getting modified during transfer.


How can we fix this error message from Appian?

  Discussion posts and replies are publicly visible