19.4 Query Entity times out

Hi All,

We have recently upgraded from 19.2 to 19.4 and facing a strange issue on few of our query entities. The query entities were working absolutely fine in production and in all other environments until we upgraded.

After we upgraded, we started seeing query entities timing out. The Data source, count of data, the way its filtered remains the same and nothing has got changed in the code. we figured out that our query has a Not Null query filter that is causing this issue in 19.4 but the same filter works fine in other versions. As of now we have removed that due to its insignificance.

But Strangely why would it break only in 19.4 and not in any older version? Has anyone faced this issue with 19.4?

(Since the query entity is originally developed in 18.3, the query entity remains a!queryEntity_18r3. Changing it to a!queryEntity also had no luck).

More insights will be helpful.

Thanks in advance

Arjun.

Parents
  • Hi,

    Please check following.

    1) Did you check in the logs for detailed error message?

    1) Did you change any query timeout settings in older versions?

    2) Try create pretty new query with same parameters and try to run the new one and see what the out come.

    3) When you say it is working other environments. Did you check the data size in the table?

     4) Are you on Cloud or On-Premise instance of appian?

    Thanks,

    Shanmukha

Reply
  • Hi,

    Please check following.

    1) Did you check in the logs for detailed error message?

    1) Did you change any query timeout settings in older versions?

    2) Try create pretty new query with same parameters and try to run the new one and see what the out come.

    3) When you say it is working other environments. Did you check the data size in the table?

     4) Are you on Cloud or On-Premise instance of appian?

    Thanks,

    Shanmukha

Children

 Discussion posts and replies are publicly visible