KB-1661 Daily performance degradation and long 'getAppianObject' calls to the content engine caused by the data collection for the Expression Rule Test Cases data metrics log

This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Symptoms

  1. Users experience short bursts of unresponsiveness and failed processes every day around the same time.
  2. There are long getAppianObject calls to the content engine. These calls can be viewed in the db_CO1*.log file located at <APPIAN_HOME>/logs directory.
  3. The times of the long getAppianObject calls in the db_CO1*.log file correspond with the timestamps in the expression_rule_test_cases.csv file located at <APPIAN_HOME>/logs/data-metrics directory.

Cause

This issue has been addressed via AN-104637 in the following hotfixes/versions:

Action

Apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Workaround

The following workaround can be used as a temporary measure until the hotfix or upgrade can be applied.

Edit the appian_log4j.properties file located at <APPIAN_HOME>/ear/suite.ear/resources, changing the following logger from:

log4j.logger.com.appian.data-metrics.expression-rule-test-cases=INFO

to:

log4j.logger.com.appian.data-metrics.expression-rule-test-cases=OFF

Affected Versions

This article applies to all versions of Appian from Appian 17.2 to Appian 18.1.

Last Reviewed: August 2018

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