KB-1747 'Import Dialog Timed Out' error thrown when importing an application or patch

Symptoms

While importing or exporting an application/patch or inspecting a package, the following HTTP error message is shown after a few minutes:

Import Error

Title: Import Dialog Timed Out Reason: HTTP Code: <502 or 504>
Message: Your import is still running in the background. Refresh this page and monitor News for notification that your import has completed.

Export Error

Cause

This HTTP error message appears when the web server times out during the activity. The web server may time out when importing/exporting large applications or patches, or when inspecting a package. The import/export will still run in the background when the web server times out.

Action

Manual Imports

Upgrade to Appian 21.4 or later as this process has become asynchronous.

Manual Exports

Upgrade to Appian 23.3 as this process has become asynchronous. The export dialog can be closed and the export will continue to run in the background.

Workaround

In order to check for the successful import, follow the steps outlined in KB-1738. If the web server times out during package inspection, the application can be broken up into smaller packages like so:

  1. Data Types, Groups, and Folders (these objects do not typically depend on other objects)
  2. Rules and Constants (constants may fail if they point to process models or record types)
  3. Process Models (process models typically depend on rules, groups, and data types)
  4. Sites, Record Types, Reports, etc. (these objects typically depend on rules, groups, and process models) 

Note: The above guidance may not be effective for all use cases.

Affected Versions

This article applies to Appian 17.3 and later.

Last Reviewed: December 2023

Related
Recommended