KB-1017 "The TCP/IP connection to the host <host>, port 1433 has failed" error thrown during JBoss startup

Symptoms

After configuring SQL Server as either a primary data source or business data source to use with Appian, users might encounter the following error during JBoss startup:

org.hibernate.exception.GenericJDBCException: Cannot open connection: java.sql.SQLException: javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:/jdbc/AppianPrimaryDS: javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:/jdbc/AppianPrimaryDS: javax.resource.ResourceException: IJ000658: Unexpected throwable while trying to create a connection: null: javax.resource.ResourceException: Could not create connection: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host *.*.*.*, port 1433 has failed. Error: "connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall."

This error is present even when users are able to access SQL Server through SQL Server Management Studio.

Cause

SQL Server has not been configured to accept incoming connections on the specified port.

Action

To verify that SQL Server is not listening on that port, run netstat -na | find "<port\>" in the command line. If no results are returned, perform the following:

  1. Run SQL Server Configuration Manager as administrator.
  2. Under SQL Server Configuration Manager (Local) > SQL Server Network Configuration > Protocols for <sql\_server\_type>, right-click TCP/IP and go to Properties.
  3. Under the Protocol tab, set Enabled to Yes.
  4. Under the IP Addresses tab, find the IPAll section at the bottom of the page.
  5. Set the TCP Port value to the value of the port SQL Server should be listening on. The default value is 1433. SQL Server Configuration Manager should look something like this:
  6. Apply changes and exit SQL Server Configuration Manager.
  7. Restart the SQL Server database.
  8. Replace all .failed or .undeployed marker files for either suite.ear (<APPIAN_HOME>\ear) or appian-ds.xml (<JBOSS_HOME>\standalone\deployments) with .dodeploy.
  9. Restart JBoss.

Affected Versions

This article applies to all versions of Appian using Microsoft SQL Server as a database.

Last Reviewed: October 2015

Related
Recommended