KB-1095 "JBAS013412: Timeout after [300] seconds waiting for service container stability" error thrown during JBoss startup

Symptoms

When starting JBoss, the following error is printed in application server log:

ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS013412: Timeout after [300] seconds waiting for service container stability. Operation will roll back. Step that first updated the service container was 'add' at address '[
("core-service" => "management"),
("management-interface" => "native-interface")
]'

JBoss then fails to deploy.

Cause

This error message is printed out when the management-native socket defined in standalone.xml located in <JBOSS_HOME>/standalone/configuration takes longer than the configured timeout value to load. By default, this value is set to 300 seconds.

Action

  1. Open standalone.conf (Unix) or standalone.conf.bat (Windows) located in <JBOSS_HOME>/bin and verify the following timeout value is large enough:

    JAVA_OPTS="$JAVA_OPTS -Djboss.as.management.blocking.timeout=3600" 
    
  2. Open standalone.xml and modify the default-timeout property in the coordinator-environment element to a larger value (e.g., 1000):

    <coordinator-environment default-timeout="..."/>
    

Note: In case the changes are not applied, clear the JBoss cache by deleting the following folders:

  • <JBOSS_HOME>/standalone/data
  • <JBOSS_HOME>/standalone/tmp

Affected Versions

This article applies to all versions of Appian using JBoss as an application server.

Last Reviewed: February 2017

Related
Recommended