KB-1485 "Inconsistent DBID on GW1" error thrown in checkengine script and engines fail to boot up with "migration.kr: file not found" error in db_*.log

Symptoms

After attempting to start the engines via the start-suite script, the checkengine script displays an error like this:

On examining the db_*.log for the relevant engine, the following error is seen:

YYYY-MM-DD HH:MM:SS [PO1] {ap39.kdb ,6713} () FATAL .a.db "migration.kr: file not found"

Both of the above symptoms must be present before proceeding to the following sections. If the migration.kr: file not found error is seen, please refer to the next section. If not, refer to the steps in KB-1211 to see if this applies to the observed issue.

Cause

The migration.kr present in <APPIAN_HOME>/server/*engine*/migration directory or the migration folder present in <APPIAN_HOME>/server/*engine* directory is missing. This may be due to deleting it accidentally or moving it to a different location.

Action

Re-install Appian and test the install/upgrade again.

Affected Versions

This article applies to Appian 17.2 and earlier.

Last Reviewed: January 2018

Related
Recommended