PDF Tools

Contains multiple Smart Services and Functions for interacting with PDF Documents.

Smart Services:

  • Merge PDF - Merges multiple PDF documents into a single document.
  • Extract PDF Pages - Extracts a range of pages from an existing PDF into a new PDF.
  • Fill PDF - Populates the fields of a PDF Form and optionally flattens it disallow further changes.
  • Create PDF Content - Allows text to be added to a PDF with control over the style, position, and angle. An existing PDF can be updated or a new one created from scratch.
  • Convert PDF to Image - Creates an array of images or a multi-page tiff from a PDF.
  • Compress PDF - Compresses the images in the PDF to make it smaller.
  • Un-protect and Copy PDF - Using the document password, create an un-protected copy of a protected PDF.
  • Convert Image to PDF - Creates a PDF starting from one or many images. It also supports multi-page tiff images.


  • Get PDF Metadata - Retrieves metadata on the PDF: page count, title, author, security, encryption, etc
  • Get PDF Text - Retrieves the text content from a PDF.
  • Get PDF Form Fields - Retrieves the populated form field values of an unflattened PDF.

  • Hi Chris 

    We've just updated the PDF Tools plug in to the current version and I note the Admin Console is showing the version as 


    Is this the correct version of the Plug In for use ? 

    Many thanks

  • Hello,

    We are trying to install the PDF Tools plugin within our on premise Appian environment, but are encountering an error message along the way. We are using (19.3 with Hotfix C) and are using MySQL8.x for the database on an Amazon Linux 2 server.

    The error is the following:

    Appian Plugin Hot Deploy] ERROR com.appiancorp.plugins.LoggingPluginEventListener - Failed to enable Plug-in 'PDF Tools' (pdftools) version 2.1.0: 'There was a problem loading the module descriptor: Fill PDF.<br/>com.appiancorp.suiteapi.common.exceptions.AppianRuntimeException: com.appiancorp.process.admin.IncompatibleSmartServiceRegistrationException: The Smart Service Module was invalid: Illegal attempt to change the data type for smart service pdftools.FillPDF, input or output named PdfFields (APNX-1-4104-005)

    I'm new to the admin side of Appian and am not overly familiar with a number of details. f this is the wrong place to pose this question, please let me know.

  • Hi Team,

    I have facing some issue in smart service ( "PDF FROM HTML"). I got the error like "java.lang.NullPointerException". I am sure and I gave all details in smart service but still cannot find the issue.

    Karthik S

  • Hi, we're running into issue with the Merge PDF feature where embedded fonts are not being deduplicated (greatly increasing the size of the final PDF). Does anyone have a method to optimize the final PDF?

  • Hello,Can you please let me know the max memory size of the pdf's that can be used to merge to convert into one using the PDF Tools plugin. 

  • Hello, we are starting a new project in an Appian Cloud environment, probably 19.3, using the getpdffields() function, is this plugin supported? What kind of libraries this plugin use? Can we assume that in further release this plugin will be supported?

  • Hello,
    we will soon update to 19.2.
    is this Version still supported?

  • Hi Is there a way where we can create a PDF from a Dynamic Template rather than a Static Template?

  • Hello again,

    I fixed it! This has been stumping my team for weeks but it was as simple to use as you described. Our problem was we were still using version 1.5 of the plugin

  • Hello,

    I am trying to follow the information mentioned in the v2.2.1 Update to add images to a PDF using the Fill PDF smart service but have had no success getting the image to map to the pdf and it does not give an error. I have tried both .PNG and .JPG images with no success.

    In Acrobat when creating the form template what field type and settings need to be in place to map the image correctly? In Acrobat for windows there is no Image form field type and on mac the image field appears to be simply an altered button type but following the instructions does not add the image to the form!

    I know my smart node is correct because passing a text pdffield as well will populate correctly but passing the image field and document id has no effect. Please help clarify what I could be missing.

    Thank you

  • , can you check the application logs and see if there are more details? Also, is the pauseonerror flag set to true or false? If its true can you change it to false and then see if you get more error details either in process or in logs? Like  asked in earlier comments please share all the details either with me (rahul.patil@appian.com) or with Sylvain, so we can try to reproduce this issue in-house.

    I am assuming you are already using the latest version of the plug-in, if not please update the latest and give it a try.

  • I also have the same issue in 18.4 when using the Convert PDF to Image smart service.

    bundleName for SmartServiceException, builder.smartServiceClass=class com.appiancorp.ps.pdftools.AbstractPDFDocumentGeneration

  • Hello Sylvain,

    We are facing the same issue in our 18.2 :

    bundleName for SmartServiceException, builder.smartServiceClass=class com.appiancorp.ps.pdftools.AbstractPDFDocumentGeneration

    Any help would be appreciated.