Appian 17.3 Installation Issue


Hi All,
I'm working on 17.3 installation, but I'm getting an error starting Elastic search, it seems like the new hotfix (Hotfix Package B) is missing a plug in or a component. Do you have any advice on the installation?

Regarding the logs it says:
[] Failed to initialize ElasticSearch node on port 9300. If other ports for this host are specified in appian-topology.xml, those will be tried as well.
java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [appian-elasticsearch-auth]. Was the plugin built before 2.0?

Thank you in advance!

  Discussion posts and replies are publicly visible

  • Hi Cesar,

    Please review the following Discussion, where the same issue occurred:

    Essentially, please try reapplying the hotfix, and paying special attention to steps 4 and 9 of the following instructions:
    1. Stop Appian.
    1.1 Shut down the application server.
    1.2 Shut down the search server.
    1.3 Shutdown all Appian Engines, ensuring that the engines are checkpointed upon shutdown.
    2. Back up your existing Appian instance. See Backing Up Your Existing Appian Instance for instructions
    3. If you are running JBoss, delete the folder /standalone/tmp/work/jboss.web/default-host/suite(including all subfolders) to clear the application server's JSP cache.
    4. Delete the search engine folder /_admin/search-local/search-server.
    5. Unzip the contents of the zip archive into your APPIAN_HOME directory.
    6. Run the (.bat) script that is now located in your APPIAN_HOME directory.
    7. Unzip the contents of the archive that is now located in your APPIAN_HOME directory.
    8. Delete and
    9. Delete the <APPIAN_HOME>/search-server/plugins/appian-elasticsearch-auth directory and its contents.
    10. If you are using a Web server, copy the content of /ear/suite.ear to the folder where the Web server is getting the static resources.
    11. Start Appian:
    11.1 Start the Appian Engines.
    11.2 Start the search server.
    11.3 Start the application server.

    Let me know if the issue still occurs after these steps.

  • delete the folder appian\search-server\plugins\appian-es-auth and then restart the search server
  • Thanks aswinb608
    perfect advice and this has worked for me
  • Kindly share the complete log.

    I suspect that Port 9300 is already occupied in your sever. Kindly check this issue too.

    But do post the full complete log and we would be able help you.