KB-1764 How to troubleshoot single user unable to log in with "PrivilegeException"
Purpose
This article is intended to provide troubleshooting steps in the case that a single user is unable to log into Appian with a PrivilegeException as shown below in the application server log:
ERROR com.appiancorp.abdera.AtomEntryCollectionAdapter - An internal error occured while accessing the tempo feed com.appiancorp.kougar.mapper.exceptions.UndeclaredException: PrivilegeException[null=>null]: User Does Not Have Rights to Perform this Operation
Instructions
- Follow the steps outlined in KB-1663 to see if the issue can be resolved.
- After confirming that the steps in KB-1663 have not resolved the issue and finding that the "Inherit security from parent" box was already checked, un-check it, re-check it, and save again.
- If these steps do not address the issue, complete the following steps (if the environment is self-managed). In addition, create a support case, so that Appian Support can further troubleshoot and provide a script to clear the group membership cache if necessary:
- Search the application server(s) for the username of the user experiencing the issue to find a login attempt in the login-audit.csv located in
<APPIAN_HOME>/logs/. Record the timestamp of the login attempt and include it in the support case. - Attach the application server log (for the date that corresponds with the timestamp found above) from the server that hosts the login-audit.csv file.
- Attach the authz-audit.log (for the same date that corresponds with the timestamp found above) located in
<APPIAN_HOME>/logs/from the server that hosts the login-audit.csv file. - Instruct the user to log in again.
- When the user logs in, take a network capture and attach it to the case.
- Search the application server(s) for the username of the user experiencing the issue to find a login attempt in the login-audit.csv located in
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: October 2018
