Related Action referring to Ghost Process Model version

I fixed my Process Model with help from the forums. When I ran the Record Related Action that was using it, I realized older version of my Process Model was getting picked.

So I made sure my latest corrected Process Model version had been published. It was and all older versions showed disabled. For good measure I deleted my Related Action on my Record and recreated it. Same problem. I know for sure the last but one version of my Process Model getting picked because when I monitor the instance and look at Variables in Process Details, I see the debug variables I had introduced.

In frustration, I deleted all previous versions of Process Model and only kept the one which works and which does not have any debug process variables. Once again, I deleted Record Related Action and created it again. For good measure, I also unpublished Application and published again.

I ran my Related Action again. SAME Problem. How in the world is my Related Action able to find a non-existent version of my Process Model and instantiate it?

 Discussion posts and replies are publicly visible