KB-1624 Appian services fail to start with InvalidKLicenseException
Symptoms
Appian services fail to start with the following type of error observed in the service_manager.log:
[KomodoEventBus-16] ERROR com.appian.komodo.engine.connection.NettyKConnection - Failed to connect to channels.
com.appian.komodo.engine.connection.InvalidKLicenseException: channels failed to start due to an invalid K license.
at com.appian.komodo.engine.connection.KProcessManager.startK(KProcessManager.java:82) ~[core-1.95.2.jar:1.95.2]
Cause
This happens when an invalid product license is used to start Appian services.
Action
Request and install a new product license as described in this documentation.
Affected Versions
This article applies to Appian 17.3 and later.
Last Reviewed: July 2018
