Advanced Document Templating

Has anyone come across the following error while opening a .docx file generated via ADT (DOCX Document From Template):

Unspecified error

Location: Part: /word/footer4.xml, line:0, column: 0

This error is only introduced after the doc is generated using ADT. The template being used works fine when opened using word.

  Discussion posts and replies are publicly visible

Parents
  • Hi there,

    Was the document generation working before? If was working, check if any new character was introduced at the template, I had a similar problem in the past, and it was related to a character that was added into the template, that did not impacted the transformation but was corrupting the generated Word document.

    The fact the the template is open fine when you are opening using Word don't actually means that the generated document will open, and as you are not getting an error in the Freemarker transformation, it is probably related to something inside the template.

    You can start removing parts of your template until you get the document generating properly, than you can analyze better what was causing the error.

    Hope that helps.

    Acacio B.

Reply
  • Hi there,

    Was the document generation working before? If was working, check if any new character was introduced at the template, I had a similar problem in the past, and it was related to a character that was added into the template, that did not impacted the transformation but was corrupting the generated Word document.

    The fact the the template is open fine when you are opening using Word don't actually means that the generated document will open, and as you are not getting an error in the Freemarker transformation, it is probably related to something inside the template.

    You can start removing parts of your template until you get the document generating properly, than you can analyze better what was causing the error.

    Hope that helps.

    Acacio B.

Children
No Data