KB-1623 JMSException thrown when trying to change the subdeployment of a JMS destination
Symptoms
When trying to change the subdeployment of a JMS destination in Weblogic, the following error is observed on the Weblogic Administration Console:
The following failures occurred: -- [JMSExceptions:045110]The JMS resource named "****" has incorrect targeting information. This resource has both default-targeting-enabled attribute set to true and has a valid sub-deployment-name value specified.
Errors must be corrected before proceeding.
Cause
This happens when the 'Default Targeting Enabled' option is enabled.
Action
Disable 'Default Targeting Enabled' and test again.
Affected Versions
This article applies to all versions of Appian using Weblogic as an application server.
Last Reviewed: July 2018
