KB-1262 "Lock obtain timed out" error thrown when starting the application server
Symptoms
The following error is seen in the application server log:
[Appian ReschedulingTimerTask - SearchIndexSyncTimerTask - XXXXX] ERROR com.appiancorp.rdbms.common.search.SearchIndexSyncTimerTask - [Search index sync: jdbc/XXXX] XXXX consecutive errors. Will try again in XXXX ms.
...
Caused by: org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out:<APPIAN_HOME>/_admin/search-local/index-primary/com.appiancorp.tempo.rdbms.EventFeedEntry/write.lock
Cause
This error typically occurs when the application server is improperly shut down.
In a distributed environment, this error can occur if the network drive where <APPIAN_HOME>/_admin resides becomes unavailable while the application server is starting up or shutting down. The network drive becoming unavailable would prevent the deletion of the write.lock file.
Action
- Stop the application server.
- Delete the write.lock file in
<APPIAN_HOME>/_admin/search-local/index-primary/com.appiancorp.tempo.rdbms.EventFeedEntry. - Restart the application server.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: June 2017
