KB-2304 Engines fail to start with java.nio.charset.MalformedInputException error
Symptoms
When starting Service Manager and engines, the following error is thrown in the service_manager.log and the engines fail to start:
YYYY-MM-DD HH:MM:SS,mmm [engine-supervisor-<ENGINE>-0] ERROR com.appian.komodo.engine.EngineSupervisor - Engine component creation for <ENGINE> has failed.
java.nio.charset.MalformedInputException: Input length = 1
Cause
This is caused by the custom.properties file, located in <APPIAN_HOME>/conf/custom.properties, not being encoded in UTF-8 format. This could happen if the file was modified and saved using an editor that does not use UTF-8 as its default encoding.
Action
- Recreate custom.properties as a UTF-8 encoded file using a text editor.
- For example, if using Notepad on Windows, choose UTF-8 under the Encoding option when saving the file.
- Replace the current file with the UTF-8 encoded one and restart the engines.
Affected Versions
This article applies to all versions of Appian on Linux.
Last Reviewed: April 2024
