KB-1231 "Group membership validation failed in process for user" error thrown after upgrade during application server startup
Symptoms
After an upgrade/migration when you try to start the application server, the deployment fails with the following error:
INFO [stdout] (ServerService Thread Pool -- 74) 2016-03-11 07:46:57,031 [ServerService Thread Pool -- 74] ERROR com.appiancorp.ag.util.Utilities - Group membership validation failed in process for user [Administrator]
com.appiancorp.kougar.driver.exceptions.Signal: type
at com.appiancorp.kougar.driver.ipc.IpcConnection.throwException(IpcConnection.java:228)
Cause
The most common cause of this issue is not all database files (*.kdb) were copied over.
Action
Copy all the engine database files *.kdb files as per the Upgrade Guide and test again.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: March 2017
