KB-1980 REFERENCES command denied to user '[user]'@'[host]' for table '[schema].[table]'
Symptoms
After upgrading Appian, the application server is unable to start and the following is observed in the application server log:
ERROR liquibase.changelog.ChangeSet - Change Set db-changelog-000168-api-key-table.xml::000168.1.2::appian failed. Error: REFERENCES command denied to user '<user>'@'<host>' for table '<schema>.<table>' [Failed SQL: ALTER TABLE <schema>.api_key ADD CONSTRAINT api_key_usrid_fk FOREIGN KEY (usr_id) REFERENCES <schema>.<table> (id)
Cause
The RDBMS user connecting to the primary database does not have sufficient permissions. These permissions might have changed as a result of upgrading the RDBMS.
Action
- Stop the application server.
- Grant
<user>full permissions on the<schema>for the Appian primary database. Eg, for MySQL this can be done with the following query:GRANT ALL ON <schema>.* TO '<user>'@'<host>';
- Start the application server.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: August 2019
