Skip to main content
parmida.borhani
Employee
March 14, 2019

KB-1928 "No configuration setting found for key 'zkServers'" error appears while trying to reset the analytics engines

  • March 14, 2019
  • 0 replies
  • 9 views

Symptoms

When upgrading an environment, the following error appears while trying to reset the analytics engines:

APPIAN_HOME\services\bin>resetAnalytics.bat -p ********** 
Exception in thread "main" com.typesafe.config.ConfigException$Missing: No configuration setting found for key 'zkServers'

Cause

This error appears when the appian topology file does not contain the zookeeperCluster element as per the following example:

<topology port="5000">
   <server host="localhost">
     <engine name="forums"/>
     <engine name="notify"/>
     <engine name="notify-email"/>
     <engine name="channels"/>
     <engine name="content"/>
     <engine name="collaboration-statistics"/>
     <engine name="personalization"/>
     <engine name="portal"/>
     <engine name="process-design"/>
     <engine name="process-analytics0"/>
     <engine name="process-analytics1"/>
     <engine name="process-analytics2"/>
     <engine name="process-execution0"/>
     <engine name="process-execution1"/>
     <engine name="process-execution2"/>
   </server>
   <search-cluster port="9300">
     <search-server/>
   </search-cluster>
   <kafkaCluster>
     <broker host="localhost" port="9092"/>
   </kafkaCluster>
   <zookeeperCluster>
     <zookeeper host="localhost" port="2181"/>
   </zookeeperCluster> 
</topology>

Action

Update the appian-topology.xml file in order to add the zookeeperCluster section. This file should be located in <APPIAN_HOME>/conf/ for Appian version 18.2 and later, or in <APPIAN_HOME>/ear/suite.ear/conf/ for Appian version 18.1 and earlier.

Affected Versions

This article applies to Appian version 17.3 and later.

Last Reviewed: April 2019