KB-1201 "User [anonymous] does not have permission on jdbc to perform lookup operation" error during WebLogic startup
Symptoms
The following error appears in the WebLogic startup log:
<Jun 24, 2016 6:14:41 PM GMT> <Warning> <HTTP> <BEA-101162> <User defined listener com.appiancorp.rdbms.datasource.BusinessDataSourceValidator failed: com.appiancorp.rdbms.datasource.DataSourceException: javax.naming.NoPermissionException: User <anonymous> does not have permission on jdbc to perform lookup operation.
com.appiancorp.rdbms.datasource.DataSourceException: javax.naming.NoPermissionException: User <anonymous> does not have permission on jdbc to perform lookup operation.
...
Caused By: javax.naming.NoPermissionException: User <anonymous> does not have permission on jdbc to perform lookup operation.
Cause
WebLogic is preventing anonymous JNDI lookups.
Action
Refer to the directions listed in Configuring JNDI Access with a Named Context.
Note: For Appian 16.1 and later, apply the latest hotfix before referring to the instructions above.
Workaround
For Appian 16.1 and later, configure the secondary data source via the Appian Administration Console.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: March 2017
