-
Recently active
I'm trying to use an OIDC connection to my Amplify page (Via AWS Cognito), but I'm getting an invalid nonce error. Is it mandatory to use nonce? I'm ignoring him on my page org.springframework.security.oauth2.core.OAuth2AuthenticationException: [invalid_nonce] Can someone help me?
When I use package details api to get package details, it response error { "resource": "/suite/deployment-management/v2/applications/_a-0000ea0b-d034-8000-9c03-011c48011c48_12019827/packages", "title": "An Error Has Occurred", "error": "APNX-1-4552-038", "message": "Cannot access package details. Either this application does not exist or your service account does not have permission to view this application's details." } I created a service account, add Appian-API-Key to header. Also add Service Accounts group to application Users Group and Administrators Group, but can't fix the issue. How to fix the issue?
Hi, Please find attached screenshot. How to remove the list of dictionary with size 'o'
Hi, I have got 2 mentions of my Process model in a health check report which 2 weeks ago # of unattended process loops"PM Name " (UUID of PM ) -> "gateway for a loop" ((more...)"PM Name" (UUID of PM ) -> "sub process node" (11 node(more...) I couldn't really comprehend , what "# of unattended process loops" really means ? Can someone explain it in simple terms ? At the moment , I am not sure whether this error is reported every time a health check is run , we run health checks weekly in our organisation. waiting to see whether this error always occurs what does the 11 nodes above means ? does this means active nodes in the instance ? do they count gateways also as nodes ? Any idea whether , we can see "# of unattended process loops" in any of the system logs ? If so , which log ? Any pointer on how to fix the issue? The PM in question , iterates over a number of DB
I would like to translate content into English(Canadian) with the help of Translation set. but English(Canadian) is not there in locale settings. Can we able to achieve this without using database. If yes, please guide me
Hi! Does anyone know how can I get the users access log? To see who hasn't logged in in the last three months, for example? I know that on the admin site in the supervision tab we can get the latest connections, but there is no history about those, and that's what I would need.
I am having trouble starting the application server on a new Appian 22.4 Windows installation. I am getting this in tomcat-stdout.log. Is there a solution to this? Thank you! 2024-06-11 15:42:49,629 [main] FATAL com.appiancorp.common.web.StartupHaltingServletContextListener - Halting JVM startupcom.appiancorp.suiteapi.common.exceptions.AppianException: java.lang.RuntimeException: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'userActivityFilter' defined in ServletContext resource [/WEB-INF/conf/security/spring-security-01-common.xml]: Cannot resolve reference to bean 'userActivityService' while setting constructor argument; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'userActivityService' defined in class path resource [com/appiancorp/common/persistence/search/AppianSearchSpringConfig.class]: Unsatisfied dependency expressed through method 'userA
Hi all, Where we can find the details in system logs when making changes to outbound email toggle under admin console??(who made the changes)
In our development environment, we have the process-analytics and process-execution engines running on one server, and the remaining engines running on another server (distributed mode). We would like to reconfigure this installation to have just one server running everything. Unfortunately, the server we want to remove is the server that runs the process-analytics and process-execution engines. Appian documentation says the following:"Appian does NOT support the removal of execution engines." My plan was to add the process-analytics and process-execution engines to the server we want to keep, start everything up so data replicates, take it all down again, and remove the engines from the second server. Would this be considered "removal of execution engines"? Or does that statement just mean we cannot completely remove an engine from all servers? Any advice would be appreciated. Thank you.
Thank you for your continued support.I would like to hear your opinions on obtaining system logs. Currently, we manually save some logs for maintenance operations. However, the number of logs is increasing day by day (especially integration logs), and we are concerned that manual management will become unmanageable. I would like to know the following three points. 1: Do you store Appian system logs separately? 2: Do you know how to automate the process of manually saving log files one by one? 3: Are there any other good ways? I apologize for bothering you during your busy schedule, but I would like to borrow your wisdom. Thank you in advance.... いつもお世話になっております。システムログの取得について、皆さんのご意見をお聞きしたく存じます。 現在、保守運用のためにいくつかのログを手動で保存しています。しかし件数は日に日に増加しており(特にintegrationのログが多いです)、手動管理では手に負えなくなることを懸念しております。 知りたいことは次の3点です。1:皆さんはAppianのシステムログを別途保管していますか?2:ログファイルを手動で1つずつ保存することを、自動化する方法をご存じですか?3:他にいい方法はありますか? ご多用のところ恐れ入りますが、先人の知恵をお借りしたく存じます。よろしくお願いいたします。
I have a question about the system logs.Is there a log that shows the process model started by the user and the processing time of each node in that process model? Thanks
how to find a process models by a particular smart services named like create user , sub process and script task....how we can filter??
I am using a!startprocess function from an interface to save some data to db, now lets say the process model being called encounters a run time error in some node, i need to show the user some custom message like ' some error occured' in the interface , onError dosent work here , as there was no issue starting the process.
Good morning, I have a question reviewing the system metrics in the logs. I have a question, is there a way to see the metrics for each application in the environment? Thank you so much
Hello All , For creating bulk users , is this the correct way I can achieve - Creating a process with UIT which will take the inputs and perform MNI on create user smart service . Please advice correct way to do this . TIA
Hi Community, Was going through documentation for breaking-a-chain and came across this point The amount of time between attended tasks exceeds the non-configurable limit of 10 minutes. Can anyone explain this pointer with example? What do we mean by when we say attended, unattended task. What is non-configurable limit and where can we see it It would be helpful if anyone provide explanation on breaking-a-chain in detail with example?
Hi all, We are evaluating using the Appian cloud database encryption, but we need to be able to access the requests audit log information. In the system logs documentation says “Cloud database audit logs are only available for Appian Cloud customers. Additionally, these logs are disabled if database encryption feature is enabled on your Appian Cloud site.” But the documentation for Appian cloud database encryption indicates that binary, error, and audit logs are available. Does anyone know what information is stored in any on these logs? Can we retrieve the information about the requests made ([timestamp],[serverhost],[username],[host],[connectionid],[queryid],[operation],[database],[object],[retcode]) from the binary log instead? Thanks in advance
Is it possible for a single user to have more than one identity when being authenticated through SAML on an Appian Cloud instance? I.e. be in more than one SAML authentication group? The user would have a primary IdP that would be first priority but would still need to be authenticated against a secondary IdP on occasion. The reason for this is that some users will need to access Appian through two separate networks, depending on their role and physical location. Each network has an AD to act as the IdP and there is overlap between the users within each AD, resulting in a scenario where a user needs to be in two authentication groups and is then authenticated against one IdP on log in, depending on the network the user is accessing Appian from.
Hi, I am using a query to fetch data based on date selection from the table in the SQL server. since the data volume will increase, I have already broken the date selected into 15 days period and then fetched the data to optimize the query. Also to optimize it more only the required fieldlist has been passed in the parameter but it was working fine till some time and now when the data volume has increased, it throws an error. Is there any other way of Optimising? The query used is: rule!NGS_queryEntityRefresh( dataStoreEntity: cons!NGS_DSE_FACT_ENGAGE_ACTUALS_QC, returnType: ri!returnType, fieldList: { "scoreTotal", "operationsCodeId", "jobRoleId", "supervisorId", "managerId", "evaluatorId", "evaluationDate", "internalEmpId", "callDate", "customerServiceQcScore", "contentQcScore", "evaluationForm", "opsRole", "evalSuperviso
We have many objects and Applications, sometimes I know the object name, but can't locate to which Application it belongs to. Is there anyway I can find the belonging Application easily?
I want to get the diff text between expression rule to integration some automation flow. Do Appian exposed any API to support such? Or is there any API could get object source by version?
Based on DR Strategy 3, documented here: https://community.appian.com/success/w/guide/3329/high-availability-and-disaster-recovery-configurations#disaster_recovery, it sounds like it's possible for an HA environment to loose nodes and continue functioning, with some potential updates to configurations. Has anyone tested this process? If you have 3 engine/data servers, if 1 node goes does, can 2 continue functioning? Likewise, if 2 nodes go down, can 1 function alone? What about search and app servers?
Hi folks, can we configure another URL masking for a particular site in an environment?current URL: www.abc.appiancloud.com/suite/sites/mysite another URL: www.abc.com/mysite.
1.What Does Nullable = True or False means in XSD ? 2. i have installed an Appian from PlayStore in Mobile . What is the server address to community .
I want to know what is the most effective strategy to handle old production processes that were designed with a methodology that involves extensive and long-lasting processes. In addition, we face numerous PRO issues that require quick solutions from the support team. Simultaneously, improvements are being made to extend or enhance the functionality of these processes. However, problems arise when we have to solve an issue that involves the modification of objects that are also being altered in the enhancements and are not yet stable. Another challenge is managing active instances with old versions of the flow; when trying to implement a new version of the process, conflicts can arise due to incompatibility between the old version of the instance and the new version of the process. Appian suggests a method in their documentation, but I find it has several limitations. I am interested to know how they handle these situations in other projects to learn from the best practices applied. do
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.