-
Recently active
Hi everyone, I'm working with Appian 25.2 on Windows, and I want to change the default HTTP port from 8080 to 80. Here’s what I’ve done so far: I did not modify anything in <APPIAN_HOME>, as per Appian's official recommendations. I located the file tomcatResources.xml inside <REPO_HOME>\conf. I added this connector definition: <Connector port="80" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="443" /> I ran configure.bat from the root of the configuration repository. It completed successfully with no errors. I did not start the Appian environment, I only checked the generated file at: <APPIAN_HOME>\tomcat\apache-tomcat\conf\server.xml And I noticed that the port is still set to 8080 instead of 80. What else should I check or configure to get the port changed properly to 80?
In the below piece of code, I'm attempting to update "id" value to 567. The output expected is the same as what is in local!groupEndpointResponse with the updated value of id. a!localVariables( local!groupsEndpointResponse:{ {totalResults: 1, startIndex: 1, itemsPerPage: 100, schemas: {"schema1"}, Resources: { {meta: {created: fn!datetime(2024, 12, 8, 3, 12, 45, 350), lastModified: fn!datetime(2024, 12, 8, 3, 12, 46, 910), resourceType: "Group"}, displayName: "Abc", members: {{display: "Joe", value: "123"}}, externalId: "null", id: 2}}}, {totalResults: 1, startIndex: 1, itemsPerPage: 100, schemas: {"schema2"}, Resources: { {meta: {created: fn!datetime(2024, 12, 8, 3, 12, 45, 690), lastModified: fn!datetime(2024, 12, 8, 3, 12, 46, 770), resourceType: "Group"}, displayName: "lmn", members: {{display: "Sam", value: "789"}}, externalId: "null", id: 2}}}}, a!f
Difference in Write to Multiple Data Store entity and Write to Data Store entity? When we need to use the multiple data store entity?
Hello everyone, I believe I created a real issue by deleting documents I should have left alone. My goal was to make environment B identical to environment A. There were existing files in environment B so my approach was to delete everything I could and then import everything from environment A. To clear away everything in environment B I hard deleted all application files by going into the application in designer, check the box next to the file name, delete, and confirm delete. Once all files were deleted I would then delete the application itself. Once all applications and their corresponding files were deleted I then went after files that lived outside of the applications. I'm fairly certain this is where I created my problem. I deleted documents that I now believe were being used for the appian user profile pictures. The documents I deleted had the format of <username>_180, <username>_90, <usernam
Hi All, we have encountered the delay in the execution of the process node (write Records) in the process model. The estimated time taken for the execution is over 2000ms, can anyone suggest, how to reduce the node Execution time and we have Expression rule in the node input of the smart Service . Thanks in advance!! regards, Manoj Yadav.
I want to display the data on the search screen when I return from the summary view using the back button.
Hello, My app has a series of reference data stored in a separate table/RT. We've permitted the user to manage that data as the values (slowly) change over time. Part of that management is to disable selections for future use by making them inactive (isActive = False). Dropdowns are used to access the reference data for creation and editing records. Only the active values are made available in the choiceValues/Labels to prevent use of outdated information. The problem is in dealing with "historical" data. There are active records created the week previous that include a reference value that was made inactive=True this week. Now anytime these types of records get edited, the reference to the retired data causes an error because selected value is not on the current list of choiceValues. I could lift the isActive = true filter on edit vs. create new record, but some of the reference values are years old and not appropriate f
Hi all, I'm using the out-of-the-box (OOB) "Download as Excel" functionality on a paging grid in Appian. One of the column values in my grid is a dash (-), which is displayed correctly in the interface. However, when I export the grid using the download button, the dash is exported to Excel as '- (with a leading single quote). It seems Excel is treating it as a text value, but I would like it to appear exactly as -, without the quote. Has anyone else experienced this? Is there a way to prevent the single quote from being added during export? Thanks in advance for any suggestions!
a!localVariables( local!data:ri!asr_Requests, local!rawEmails: ri!asr_Requests.emailAddresses, local!integrationResult, local!isintegrationSuccess, local!individualEmails: reject( a!isNullOrEmpty(_), a!forEach( items: split(local!rawEmails, char(10)), expression: trim(fv!item) ) ), local!invalidEmails: reject( a!isNullOrEmpty(_), a!forEach( items: local!individualEmails, expression: if( regexmatch( pattern: "^[A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,}$", searchString: fv!item, regexFlags: "si" ), null, fv!item ) ) ), /*local!formattedEmailString: joinarray(local!individualEmails, ","),*/ local!formattedEmailString: a!toJson( { emails: joinarray(local!individualEmails, ",") } ), local!validationMessage: if( a!isNotNullOrEmpty(local!invalidEmails), "Emails must be valid and each on a new line.", {} ), a!formLayout(
Hello, I’m working on a bidirectional integration between Appian and an external system via a middleware gateway. In this setup, we often encounter two categories of errors: Technical issues Data issues Errors series (500 and 400) [emoticon:71aee13fb1eb4feea8d56f3f0189f580]My question: What are the best practices for functionally handling these types of errors on the Appian side? Specifically: Should we simply display messages to end users via pop-ups or alert banners? Are there recommended design patterns or built-in Appian features we should consider (such as retry logic, logging strategies, fallback mechanisms, or dynamic UI error messages)? Any advice for differentiating user-facing errors from those logged for admin troubleshooting? Thanks in advance for your insights!
Good day, fellow Appian developers, I have a question about best practices regarding managing document uploads conditionally. Scenario: I have about 11 user tasks in a new application. Each task has different business logic regarding what documents can be uploaded and how. For example: On the first task, only documentType1 and documentType2 can be uploaded. documentType1 can be uploaded only once and must have a .docx extension. documentType2 can be uploaded multiple times, with no restriction on file extension. Business rules will vary from task to task. Additionally, this setup is currently only applicable for country1/organization1. Over time, this process will be adapted for seven organizations/countries. Each organization will have different business rules about what documents are required and how they can be uploaded in each task. Since this involves quite a number of validations, what is the best practice for creating a generic document upload component that can work ac
Is there anyway I can use github copilot to analysis my application.
Hi everyone, just wanted everyone's opinion on one of our process. We have multiple categories for which we have different set of user roles. They are stored in DB like category 1 -> category 1 roles with their users. And the count of rows is roughly 4000 in production. Role are 1 till Role 11. Categories are like 100+ and there can be multiple users for a role. Also, we have few user groups for few of our oversight roles so whenever there is change we add or remove users from group. So the thing is for Role 1 - Role 6 we are checking throughout application by querying the record with a batch size of 1 and with a single field, if it returns we believe the user has that set of access and we show the screen accordingly. For the rest we use if they are part of user groups and show the content accordingly.My question is what would be a better approach for this? To have groups for all roles and then whenever there is a change add/remove in all user groups? Won't t
After upgrading to Appian 25.1, the logs indicate that all services are up and running. However, HTTPS calls to port 8080 are not working. Am seeing the following warnings in the logs: “Ignoring JAVA_HOME; using ES_JAVA_HOME instead” “Unable to load the config file: /home/.aws/config — Access Denied Exception” Any help in investigate why port 8080 is not up and running would be much appreciated? All 15 requested services are running [analytics00, analytics01, analytics02, channels, content, download-stats, execution00, execution01, execution02, forums, groups, notifications, notifications-email, portal, process-design] 0 [main] INFO com.appian.data.server.Watchdog - Data Server is starting using the [ALL_COMPONENTS_MODE] startup mode.18 [main] INFO com.appian.data.TopologyFactory - Loading topology /usr/local/appian/data-server/conf/appian-topology.xml *************************************************************************************
After upgrading to Appian 25.1, the logs indicate that all services are up and running I dont see any error. However, HTTP calls to port 8080 are not working. We’re seeing the following warnings in the logs: “Ignoring JAVA_HOME; using ES_JAVA_HOME instead” “Unable to load the config file: /home/.aws/.config — Access Denied Exception” All 15 requested services are running [analytics00, analytics01, analytics02, channels, content, download-stats, execution00, execution01, execution02, forums, groups, notifications, notifications-email, portal, process-design] 0 [main] INFO com.appian.data.server.Watchdog - Data Server is starting using the [ALL_COMPONENTS_MODE] startup mode.18 [main] INFO com.appian.data.TopologyFactory - Loading topology /usr/local/appian/data-server/conf/appian-topology.xml ************************************************************************************** Regenerating the server certificate.warning: ignoring JAVA_H
Hi, We need to get the users access and refresh tokens using the SAML assertion. We tried to do this creating a connected system with the authentication method OAuth 2.0: SAML Bearer Assertion Flow. The problem we have with this solution is that the assertion along with the client id, client secret and scope are added as a header when calling the integration. We are required to send the assertion separately in the request body, so we are trying to find a way to get the assertion after the users login with SAML to add it to the body of the integration to retrieve the tokens. Has anyone done something like this before or knows how we can access the SAML assertions stored in Appian? Thanks in advance.
below question: Can we capture the user activity in Administration console or designer page even if the user is not changing anything there , user start pages ,etc. and they are not making any changes , Is this activity also captured in the logs and if it is which log should I find it?
Hello, We are operating on-premise and retrieving user login data from /opt/appian/shared-logs/appian-engine-1.xxx/login-audit.csv across three servers. It has been noticed that the files in /opt/appian/shared-logs and /opt/appian/logs are not synchronized. Is this expected behavior? Additionally, could you confirm the timing for when the login rotation file is generated and copied from /opt/appian/logs to /opt/appian/shared-logs? We observed that the rotation file in /opt/appian/shared-logs is created at random times rather than at 12:00 AM GMT. Thank You, Sneha.
Is it possible to enable SAML Authentication (SSO) specific to one application alone in a shared environment and remaining users are expected to login via native login for accessing other applications in the same environment?
When I navigate to the System Logs tab, I saw there are different type logs in there. Is there any best practice of developer to check these logs?
I need to create thousands of test users in my system to support locust test. Are there any tools that allow me to do that?
Hi, We have the following requirement and would appreciate the community's support to suggest the best practice for achieving the same. Business Requirement : A process for loan is triggered in a branch (CRM system) where all the customer and loan related details are collected and then submitted to another department(Credit department) in the bank. All the UI and process related to branch is implemented in CRM, whereas credit department UI is implemented in Appian(review of submitted application happens in credit department). if any discrepancies are found in the application, credit department can send the application back to branch(CRM) and once corrected flow will continue in Appian. This return to branch/ different roles within the branch can happen multiple times at various points during credit department review Suggestion required on below approaches: Approach 1: In traditional BPM systems, we create a Dummy task in BPM to indicate the external system task(CRM), once this tas
Is it possible to have a session countdown timer in the UI, when the user goes into idle state. When the session timeout pop up message appears, is it possible to have a count down timer to show the remaining minutes before logout
fff
Facing below issue while trying to enable SSO. I have filled out the SAML form with all the required information. When I am testing the configuration, I am receiving error message as below. FYI, IdP is Azure Ad. I see below message from Logs Interesting part is, Azure logs says that my login is successful even though I have above error message displayed in Appian. Did anyone face similar issue or know about this issue?
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.