-
Recently active
Hi there. If I select the “Generate groups and folders to protect and organize objects” option when creating a new Application, what groups are created by default? I think they were “Administrators” and “Users” but I saw in a forum that someone was talking about the “Designers” group being created as well. Is this true?
Hi, I have section of questions using 15 fields of a cdt (cdt has total 30+ fields). Based on a dropdown value change, I want to make all 15 fields to null. Is there any way I can make all 15 fields to null in one go, instead of writing 15 a!save.
Hello Devs, I have created a webAPI of template type : "StartProcess". Now this webAPI is starting the process when triggered but I want to open a form as a result of it. How can I achieve that? Do I have to handle it inside body ? inside httpResponse of onSuccess? how to achieve that. Here is my current code for the webAPI: a!startProcess( processModel: cons!PFM_APPIANFORMTOLAUNCHROUTER_PM, processParameters: { formToLaunchLabel_txt: http!request.queryParameters.formToLaunchLabel_txt, formToLaunchParameters_txt: http!request.queryParameters.formToLaunchParameters_txt, processInstanceAppianId_int: http!request.queryParameters.processInstanceAppianId_int, }, onSuccess: a!httpResponse( statusCode: 200, headers: { a!httpHeader( name: "Content-Type", value: "application/json" ) }, body: a!toJson( { taskID:getactivetaskidsforprocess( fv!processInfo.pp.id ) } ) ), onError: a!httpResponse( statusCode: 500, headers: { a!httpHeader( name: "Content-Type", value: "application/jso
The following error appears in the logs every 5 minutes from feb 15 , and it seems like the leader election is occurring at this interval for some reason. Is this something to be concerned about? Should I open a support case, or is this behavior normal? Could you please clarify? [2025-02-19 08:53:03,034] TRACE [Controller id=0] Leader imbalance ratio for broker 1 is 1.0 (kafka.controller.KafkaController) [2025-02-19 08:53:03,034] INFO [Controller id=0] Starting replica leader election (PREFERRED) for partitions triggered by AutoTriggered (kafka.controller.KafkaController) [2025-02-19 08:53:03,034] DEBUG [Controller id=0] Topics not in preferred replica for broker 2 HashMap() (kafka.controller.KafkaController) [2025-02-19 08:53:03,034] TRACE [Controller id=0] Leader imbalance ratio for broker 2 is 0.0 (kafka.controller.KafkaController) [2025-02-19 08:58:03,034] INFO [Controller id=0] Processing automatic preferred replica leader election (kafka.controller.KafkaController) [2025-02-19 0
We are trying to find out the current utilization of LIMS so wanted to know if you have any monitoring tools to check the current active users
Hello i m follow this guide https://academy.appian.com/#/online-course-player/270dc9fc-ad42-4d30-94db-ebfcc2f39331 But on Create the Part Record Type in step 8 I have this error when I click on new relationship. HTTP Code: 500 APNX-1-4198-000 Error Evaluating UI Expression Expression evaluation error [evaluation ID = KP48I] : Error in a!forEach() expression during iteration 1: Expression evaluation error at function a!getInterchangeableTypes [line 27]: The data source [_a-0000eada-3d9b-8000-9ba4-011c48011c48_12846-w1857] was not found Can you help me please? Im new in appian. Best regards!
Is there any possibility that load() and with() will be discontinued ?? is there any possibility that load() and with() will be deprecated We have a!localvariables to do the same thing more efficiently.
Hi Team, I have below text and I want to convert it into a Date and Time. Example: Text: "01/07/2025 12:00:35 PM" Date and Time: 01/07/2025 12:00:35 PM or 01/07/2025 12:00:35 PM GMT+00:00
i just have a general question about this statement in the documentation, "By default Appian runs with 3 shards each of the execution and analytics engines. The maximum number of shards for each of these engines is 32. Because they store unique data, once you have added a new shard for execution and analytics, you cannot remove that shard from your configuration." Does this mean one engine can have between 3 to 32 shards? 1 : 3 ... 1: 32. Thank you.
I have an process model , getting ids and looping via batch vise. Im npt getting a error or data is not updating the same process model is showing in the Health Check Report that {<PROCESS MODEL NAME>tGet list of caseIds scheduled to process- (11 nodes in loop)}
Hello All, Our new RHEL9 Acceptance environment is upgraded to version 24.3 but after upgrade we are unable to access the one app server directly (without load balancer). Previously we could access app server directly using URL "https://{HOSTNAME}/suite/?signin=native" But now I can login but it gives me CORS request rejected error message. Previously before upgrade I added {HOSTNAME} to embedded interface list in admin console and it was working. can you please help me in this how to bypass or update CORS valid list directly in database. Not sure but looks like it is wiped out after upgrade. Here is error details : 2025-01-14 22:50:40,903 [ajp-nio-0.0.0.0-8009-exec-1] ERROR com.appiancorp.security.cors.CorsFilter - CORS request rejected; invalid request from XXX.XXX.XXX.25 to /auth jakarta.servlet.ServletException: CORS origin denied: {HOSTNAME} is not on the allowed list:[ Thanks, Bhushan
Hi, We have a requirement that some communications between Appian and external systems have to be encrypted with mTLS. Does anyone know what is needed to generate a mTLS certificate and how to configure it in Appian? Thanks in advance
Hi all, I am writing with regards to an issue that we have found while upgrading from Appian 22.4 to Appian 24.3 in both the Dev and Test environments.We followed the procedure described in the documentation and found no issues during the upgrade process. However, when starting the Appian engines, we noticed the 3 analytics engines and the 3 execution engines were in CRASHLOOPBACKOFF state. The other engines were in RUNNING state as expected. We resolved the issue running the recovery script with these parameters: ./recovery.sh -p <password> -s <failing_engines> -ni Then, the engines started correctly, and all the servers started up fine as well. However, the exiting process instances had disappeared from the Appian design view. Is there any way to refine the parameters used in the recovery script or another solution to recover the engines in CRASHLOOPBACKOFF state? As the same issue has happened in the Dev and Test environments we are concerned that it could happe
I have got a input string like "[key1:value1,key2:value2]", how to get the value by key?
1) Which log file is used to view users' activity like password Chage, user type change, reactivate/deactive, username change? 2) Which log file to view the process failure in detail? 3) Log file to view the user login audit? 4) Log file to give details about slow queries?
It doesn't appear the option from the menu
We are running a HA env with 3 app servers behind the Apache. We are using mod_jk and JKWorkerProperty to set up the load balancing in httpd.conf as provided in the Appian documentation. Issue is, we notice that whenever one of the tomcat servers are down, requests are still routed to the instance. This doesn't happen when entire instance is down. I assume Apache is doing a basic TCP to determine the health of the backend server. I want to know if I can configure a tomcat health check GET url in my Apache config to determine the health of the instance from apache?
How to get the memory occupied by the knowledge center documents in Appian server? Tried with Admin console -> Monitoring, and it is providing size for the list of documents uploaded/downloaded? My requirements is get the actual space occupied by the knowledge center documents in Appian cloud environment.
Dear Team, I am new comer to Appian have background of IBM BPM, Can you please guide where to find inner exception details (log for this error) of a smart service ( Move to Collab). It is giving error com.appiancorp.suiteapi.process.exceptions.SmartServiceException: java.lang.Exception: Invalid File Path: /webattachments/path/foldername//info@alwaha-qatar.com/qid20220327080031286QID_&_PP.pdf we are using to move files from file server to appian mount path but it is completed sometimes & gives above error some times.
Are there any official, generic guide lines when it comes to retention of information stored in the database and the documentation stored in knowledge centers (when to archive, eliminate, how to handle such situation)? It's obvious we'd have to tailor it to our specific application but I wanted to start by observing any suggestions given by Appian. Best Regards.
I am getting some entries in Health Check report for USRX-0041: "# of slow process tasks". There is no information link about this specific issue to https://docs.appian.com/suite/help/24.4/understanding-the-health-check-report.html I could see that all our HIGH risk entries are process tasks with interfaces. Does anyone know how to properly solve slow process tasks? It's related to the average time spent loading/rendering the interfaces? I can see that some of those interfaces are not present on the "# of slow interfaces" item.
Hi All, I am having a specific situation where I need your feedback and suggestions. There is a Record A pointing to Table A and Record A is having relationship with Record B (Table B). For some reasons I have created Record B1 pointing to same Table B and added the relationship in Record A. What could be the issue / performance issue with this type of relationship? Note: This is only one relationship I have explained in above example, in actual we have more then 10 such relationships.
Is there any way to update process Calendar using process Model without giving the administration access to user by using interface.
Hello, In Admin Console, we have configured "Idle Session Timeout" as 20 minutes . The users authenticate using SAML via SSO login. However, we observed that the session is not timed out in 20 mins always. If we open multiple tabs, certain tabs are timed out whereas few are still logged in after 20 mins. Is there any reason or configuration change which needs to be done? Thanks in advance..
Hello, I have a use case where i have to provide all record Id's and record name in Picker Field. Users can select from it. I have been fetching only id and name column from DB table . Now the records count is less ,so it is fine. But in future if I have more Records what would be the Best Approach I can take on this. Thanks in Advance!
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.