-
Recently active
We have two fields drillTime and drillDateTime. Condition: If there is a value in drillTime print drillTime or if it is null Print drillDateTime [#if dmd.drillTime??] ${dmd.drillTime!""} [#elseif dmd.drillDateTime??] ${dmd.drillDateTime??} Above we used in template but its not working correctly. Its printing drillTime if there is a value in it and if it is null its not printing drillDateTime. Note: drillTime is text and drillDateTime is date and time type.
Hello All, I have created a table in Mysql Database and facing the below error when creating CDT against the same table in Appian. Error Message: The data source [name=jdbc/appian] cannot be reached, does not exist, has been deleted, or you do not have sufficient privileges to access its data. Note: I can able to query and update the tables in the same data source. Appreciated it if anyone can answer this issue. [mention:b45a4f6a20b14a008e4e0ec732a8bf98:e9ed411860ed4f2ba0265705b8793d05] [mention:126a676c85024855948336691b0a7b92:e9ed411860ed4f2ba0265705b8793d05] [mention:8b930cc189ea4ddf8fcb9c275d619049:e9ed411860ed4f2ba0265705b8793d05] Thanks,
Hi, In my Linux server with appian 20.4 installed, the following are the details in the "profile" file in /etc folder --export JAVA_HOME=/data-01/appian/203/appian/java ---- actually this path does not exist in the serverexport PATH=$JAVA_HOME/bin:$PATH: But when I run the command echo $JAVA_HOME, I find this -- /usr/lib/jvm/jdk1.8.0_191 I tried removing the java folder, in the above path(/usr/lib/jvm/jdk1.8.0_191) and stopping my Appian services, (firstly the Tomcat) but the jsp commands are unrecognisable. As soon as I restored the Java at the above path, everything resumed fine. The JAVA_HOME in the profile file refers to a different path while the actual JAVA location used by my services seems to be different. Can any one guide me to change the JAVA_HOME path? Can I point my Appian services to use the the Java in this path (/data-01/appian/204/appian/java)? If so where should I set the path for my Appian services to point to this path? Thanks, Chetana
Hello community, Context: We have an application (eg.: APP Groups) to manage the security for a second application (eg.: APP Application) with all the necessary groups. Our team have a requirement to allow the user to create a group without having to access the Appian Designer, so we are using the "create a group" smart service (https://docs.appian.com/suite/help/22.1/Create_Group_Smart_Service.html). Problem: This smart service works but it doesn't allow us to add the object in the groups application. There is any way to, when creating a group, passing the indication (through smart service or function, for example) that this group is to add to the group application? We need to be able to move this objects through environments, so they need to live inside this application. Thank you.
Hello community, did you try use in the html template js or css by using external sources? My observation shows that Appian probably cleaning up the external sources. So, do you have any experience how to prepare nice html templates from Appian? Thanks in advance, Pavol
I need to create tasks to create user roles in user stories can any one help me with the points that need to be add
Hi All, Just wanted to know if we can provide a Basic user access to the Admin console or should the user be a System Admin only to access the same? Thanks and Regards, Sumit Kumar Jha
E-mail notifications are quickly driving everyone in our team crazy. While I can think of some workarounds, before I go about implementing that, I was wondering if there was any built in functionality to configure a sort of end of the day digest e-mail for any of the following: - user input task notifications - error messages - emails from the send email smart service
Hi Team,Does any one have an idea about below error? Am seeing error at tomcat logs.2022-03-23 00:01:55 INFO [ConnectionTimeoutBasicDataSource-124984] com.appiancorp.a2.vpn.VPNTunnelNameService.lookupAllHostAddr DNS Lookup using VPN DNS servers: DB Name.company.net.We are using on-premise database which is available in our company.ThanksmSai.
Hi, I am managing multiple Appian environments and would like to know how I can monitor license usage for each environment separately. Within each environment, I also need to monitor license by user group and license type. Curious to know how others have approached this problem in the past. Thoughts? Thanks!
In the Appian Health check page. I am getting this error. Anyone help me to rectify this error. Thanks in advance. Error: A deprecated Appian Health Check plug-in has been detected on this environment. Remove this plug-in in order to continue running Health Check from this page.
Hi Readers, To one of my site, in site settings for this parameter i have kept as never "Show Tempo Link in Navigation Menu: Never" To my Knowledge this means whether the site need to be visible in the list or not when this button is pressed. but there is a site which is visible in navigation menu even though when Show Tempo Link in Navigation Menu parameter is set to Never would like to know the reason. Let me know if any other parameters are reason for this Thank You
ihave one radio button in editable grid so when i select one option it should be disabled how can i do it
I unknowing made myself as a Basic user in Users View in appian Designer if i want to undo the operation the system administrator option is disabled how can i get again my system administrator permission back in the appian community site
Hi, When we are trying to deploy manually to QA envi, it is taking too long and it is getting timed out. However, deployment process is running in the background and after a couple of hours the deployment is getting completed. The size of the patch is as less as 60kb, but still it is taking too long. The version we are currently using is 20.4 with latest hofix installed. Thank you.
While upgrading from 20.3.1370.0 to 21.4.600.0, received below error. i.e. Numerous errors for each user data, 2022-03-15 12:21:31,341 [localhost-startStop-1] ERROR org.hibernate.util.JDBCExceptionReporter - Violation of UNIQUE KEY constraint 'usr_username_uc'. Cannot insert duplicate key in object 'dbo.usr'. The duplicate key value is (testuser1). We've not received these type of "Violation of UNIQUE KEY constraint primary data source" error when we did Appian upgrade / HF in the past.Not sure, if this is part of Appian Product Issue. We're using the recent 21.4.600.0 HF released on 11th Mar 2022 - hope this is stable HF ver. and Appian not aware of any such "UNIQUE KEY constraint primary data source" issue? Just curious to know if anyone received this error when Appian upgrade...Any suggestions / guidance to handle this type of error please? - Thanks.
Hi Team, I have the health check report from production. I can see there are various categories and tabs as part of the report.Is there any standard practice to resolve the order of health check reported issues like first process metrics related issues,infrastructure related,configuration, design etc.
I was tried to connect the multiple environment in the Devops: Infrastructure. But I am getting this below error. I am getting the server log like ERROR com.appiancorp.connectedenvironments.logging.DevOpsInfrastructureAuditLogger - [ERROR, null, null, https://<other_site_subdomain>.appiancloud.com/suite , OUTGOING, null, null, null, null, null, null, null, null, null, URL did not return a valid public key: Please help me out to rectify this error. Thanks in advance.
We have an app where many users needs to have access to the app "in case" they need the app. Not sure how to explain this but we created an app to track an event and each event is characterized by a product. A person is assigned to the product. We have many products so many people use the app. However, the event may never happen for that product or happens once a year for that product. So the user may only log in once a year to handle the one event or may never log in if an event never occurs for their product. Does anyone else have this type of situation? And if so, do you have a good method for managing this from a license perspective? I have heard of a API or tool called IGNIO that helps with turning licenses on and off on an as needed basis. Thoughts?
Hi All, is there a log or any other way to find out the process models configured with timer event in start node ? Thanks!!
Hi Readers, I just want to know how to set the default site for an application. There are three application which i am using and the first application is which i use mostly, so i want to view my first application when i login in appian, and i can navigate through the rest using navigation bar. I think we can do this by assigning the default page to a group.; but i am not able to do it please guide me
Hi, I am trying to gain clarity on which users count towards a Appian license. I understand that only active Appian users consume licenses. I also understand than an active user is a user who has an account in the Appian environment and whose account is flagged as active. What I am not clear on is when that account becomes active. Does a new user account become active once the account is created OR once the account is created and the user has logged on? Anything else I am missing? Thanks, Barthe
Error The System Has Encountered an Error HTTP Code: 503 The system has encountered an error. Please try again later. Any idea how to fix this ? Please note that this is export not import . It seems the process is hanging at inspect stage ? Anyway to skip inspect or increase the timeout . problem is that unlike import there is no way to attach a property file ? I don't think export is happening at the background as tomcat log file has no mention of export. SYSTEM INFORMATION Appian Version 21.4 Execution Engines 3 Application Server Configuration Single Hosting Environment Appian Cloud
Hi, We are in process of adding environments in admin console under Devops: Infrastructure. We have added URL of either environments in console. We are getting following error while adding environment. URL did not return a valid public key. Any help in this regard is welcome ...
I'm not able to register for the Appian World 2022 Live Build Challenge Registration. Every time I click on the "Apply Now" button. It redirects me to the below screenshot: Can someone help me out?
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.