-
Recently active
Hii All, Can we able to migrate entire Environment data from one environment to another environment including Users Everything,is there any approach? Thanks a lot in Advance
Hey everyone,My company provide Appian as an on prem solution for a client. We need to upgrade the servers we are running their Appian on to Windows 2016 server. I know it's quite an old version of Appian however the client has no interest in upgrading, so I just need to know if Windows server 2016 supports Appian 2016.1.0.0Thanks
Does anyone know what is the earliest version of Appian that uses Tomcat 9,0.76?
After installing latest hotfix 23.2, we cannot start the Appian Service Manager windows service. Here is the error: Service Kafka failed to start Error running script: Unable to start transaction log. com.appian.komodo.StartKomodo$TransactionLogNotStartedException: Unable to start transaction log. at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:423) at org.codehaus.groovy.reflection.CachedConstructor.invoke(CachedConstructor.java:72) at org.codehaus.groovy.runtime.callsite.ConstructorSite$ConstructorSiteNoUnwrapNoCoerce.callConstructor(ConstructorSite.java:105) at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallConstructor(CallSiteArray.java:59) Unable to start distributed tran
Is there any official recommendation or does anyone happen to know of any benefit of removing intermediate versions generated while working on an object. For example I'm working on an interface and I happen to save my changes 55 times during the development on the page...... so I have 54 versions saved that I don't need since I only want to save the last one. Other then making the version history cleaner to go through is there any other benefit?
We applied Hotfix 23.2.346 and Kafka will not start when restarting the Services Engines using the Windows Services. The error log shows the following: Starting Appian Service Manager Found k.sha256 - a74b78fd5ab833a02c740879b7e962074e9b823cf9a08029ddaa003c03e51684 Detected Appian version 23.2.346.0 from build.infoStarting Distributed Transaction Log services: [all]Executing command: '[cmd, /c, start, "Zookeeper", /min, "%JAVA_HOME%\bin\java.exe", -Xms128m, -Xmx256m, -Dzookeeper.log.dir=e:\appian\logs\service-manager\zookeeper, -Duser.timezone=GMT, -cp, e:\appian\services\zookeeper-3.8.1\lib\zookeeper-prometheus-metrics-3.8.1.jar;e:\appian\services\zookeeper-3.8.1\lib\zookeeper-jute-3.8.1.jar;e:\appian\services\zookeeper-3.8.1\lib\zookeeper-3.8.1.jar;e:\appian\services\zookeeper-3.8.1\lib\snappy-java-1.1.7.7.jar;e:\appian\services\zookeeper-3.8.1\lib\slf4j-api-1.7.30.jar;e:\appian\services\zookeeper-3.8.1\lib\simpleclient_servlet-0.9.0.jar;e:\appian\services\zookeeper-3.8.1\l
Hi All, We are working on getting appian data to splunk. Appian has been configured to push the logs to splunk syslog endpoint. We have tried several things but the data received in splunk is still encrypted. https://docs.appian.com/suite/help/21.2/Log_Streaming_for_Appian_Cloud.html#prerequisite-checklist Below is the config of splunk. Please help us if you have done this is past or have knowledge on how to fix this. etc\apps\search\local\inputs.conf [tcp://514]connection_host = ipindex = appiansourcetype = syslog [SSL]requireClientCert = falseserverCert = $SPLUNK_HOME\etc\auth\splunkweb\myDataCertificate.pemsslVersions = tls1.2cipherSuite = ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:DH-DSS-AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384:DH-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA256:DH-RSA-AES256-SHA256:DH-DSS-AES256-SHA256:ADH-AES256-GCM-SHA384:ADH-AE
Developers can monitor process instances of their application but should not able to edit anything in UAT. Deploying application/package/plugins from UAT to PROD. Creation of new users and adding them in respective groups Editing of process instance in monitoring mode
Is there a way to filter the system logs by application? The use case is as follows: Our client has a ton of applications in their environment but they would like to consume/analyze the logs externally (using logstash for example) just for one specific application. That includes all types of logs (record usage, user login, design errors, etc.), not just one specific type (although I would think not all are applicable to be filtered). Any thoughts around this?
Hi Appian Community,Does anyone know how to put Appian into maintenance mode without using the GUI? Is there a configuration file that can be modified, or a binary that has this functionality?We maintain our Appian stack through a series of automated scripts, and it would be nice to be able to put our stack into maintenance mode before other actions are performed.Thanks!
Hi! I created an app and I wanted not to let certain groups to execute record actions. I changed the security in the process model, so that only admins can be the initiator (same in rest of the objects), but when I eliminate myself from the group admins I still can execute the actions. But the fact is that the views of my site in fact work if I change myself from groups. Why aren´t related actions permissions working?
Is it safe to change a group's Parent group or also to change a groups name if it has already running task instances.
Hi , Third Party Credentials questions. 1) Is it possible to update Third Party Credentials using API or any other option other than Manual. We are rotating our client Secret every 6 months so don't want to do it manually, exploring option to automate this process. 2) Does Appian provide audit of updating Third party Credentials. e.g if we have S3 credentials and if someone updates client secret then does appian capture this update in any log ? Thanks Vishal
In signature field , i am unable to configure target document. could any one help me out !!!
Appian is throwing error while statrting the application, by saying QRTZ_LOCKS table is already present. Few points about the environment are below 1. It is new Appain additional server(like UAT2 or SIT2), this is the first time we are trying to start the instance. 2. The db schema(oarcle DB) was copied from lower environment(i.e. i contains all the tables Business and meta data. as same schema has been used for both) 3.We cannot drop/rename the QRTZ_LOCKS table, due to some internal reason. Can we skip this table creation part by anyhow? Where can i get the complete list of appian meta data tables? Kindly help me to resolve this issue.
Hello Everyone, I want to check the current license status of our Appian environment. Is there a page to manage licensing? Thanks, Chaitanya
A task within a process for which you are an administrator requires your attention. The task currently has no valid assignees and will not be completed without intervention. Please click the link below to go to the task and reassign it to another user or a group with members.Priority: Normal Even though the task is assigned initiator. I am getting this error. Any suggestion on this?
Due to resetting one of my colleague's phone, he lost the Google Appian authenticator! Is there any way to reconnect with the Authenticator?
Hi, for the log transmission through AWS private link it says that I should have an Advanced account in Appian. Can anyone tell me the steps to get the Advanced account?
Hello, we take data from Active Directory(AD). We use the "LDAP User Profile Synchronization" node to synch data from AD to Appian. We have a requirement to consider email based on the below condition. "If CallingCardNumber = Migrated then consider the value from mail attribute or else consider value from PrimaryEmail attribute". How can I add a condition in this "LDAP User Profile Synchronization" node's "User Email" field? Thanks in advance. Jigna
which type of record is best to use in appian? and in which scenario we should use entity backed record, process backed record and service backed record?
Can some one suggest on this please. Thanks.
HI, I'm adding a new SAML configuration for Okta and to save it I have to make a successfull verification before. The problem is we fail to establish the connection so the Test return false. When the user tried it has the error below : "Authentication was unsucessfull Reason : the user tested with was invalid" Nevertheless, the user connected is a valid user of the Appian application (and is system Admin). Regarding the Tomcat logs, I see this error : 2023-06-22 10:18:13,730 [http-nio-8080-exec-1535] ERROR com.appiancorp.security.auth.saml.SamlTestServlet - Error occurred during SAML authentication test: Invalid Username com.appiancorp.security.auth.saml.exception.InvalidAppianUserException: Invalid Username at com.appiancorp.security.auth.saml.SamlAuthenticator.getAppianUserProfile(SamlAuthenticator.java:100) at com.appiancorp.security.auth.saml.SamlAuthenticator.authenticateUser(SamlAuthenticator.java:54) at com.appiancorp.security.auth.saml.SamlTestValidator.valida
Hi Team, I created an Appian account on June 26th, I requested for Community edition site. when can I expect the Site? Regards, Chandra
Hi,Is Maintenance window in Admin console activation and deactivation records any logs?if so can anyone let me know the location to find the maintenance window logs? We would like to know who and when made this maintenance window changes. Thanks,Venu.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.