-
Recently active
Hi All, I have started my Appian journey and want to understand the roles and responsibilities of an Appian analyst plays in the SDLC lifecycle. Have gone the Appian Software Development Life Cycle (SDLC), but it has point of view from the developers standpoint. So looking towards the community to guide me in the appropriate direction. Thanks.
Hi all, I have configured PDF merge and Extract PDF pages smart services for my use case. Both of them are working as expected when I initiate process model as administrator access. But, when I am initiating PM as viewer permissions the output variable newDocumentCreated is not able to save the value. Please see the configuration details below. Please let me know if I can achieve this by any other way.
When we have Designer access to an Appian environment, currently we are able to view the objects of all the Applications present within that environment. In our client environment, there are multiple applications in which developers from multiple organizations are working on. Our team needs to have access to only one particular application that we will be working on and should not be able to see other Applications present within that environment and all its objects. Is there a way to restrict developers with designer access to see only a particular application that they are working on and not see all other applications? Thanks in Advance.
Hi Guys, Any idea when the Appian Community Edition will be upgraded to v22.2 so we can checkout the new functionality (which looks awesome). Thanks, Teele
Hi All I am trying to deploy the container from Dev env to test Env , but while deploying I am getting an error that "The interface xxxxx is being edited by xxxxx so and so " I have closed all the application and restarted the system too but didn't able to resolve this error . Please help me out to resolve this error . Thanks in advance
Can we access to Appian Community Site even after we left our current organization . The credential email id is associated with the current organization domain name.
Hi, we upgrade to 22.1 and now we have issue with sending mail , using Sent mail smart service and also sending alerts on a task level. The problem is that this does not happens with all of the mails. I will like to review our mail setting and ask do we need following lines in custom.properties or not conf.suite.MAIL_SCHEME=httpconf.suite.MAIL_SERVER_AND_PORT=localhost:8080 Our other setting is conf.mailhandler.ntf_sndr_addr=mail@company.mk conf.mailhandler.mail.smtp.host=smtpserver.company.mk:26 conf.mailhandler.email.domain=company.mk conf.mailhandler.mail.smtp.auth=false conf.mailhandler.mail.transport.protocol=smtp Thanks in advanced. BR,Natasa
Hello: I am seeking advise for vertical scaling of a single server, in regards to adding more engines in the appian-topology.xml configuration. We are currently running the default topology with three analytics and three execution engines. Our server have 16-CPU cores and 64GB of RAM, and I am looking for suggestions on how may engines would be ideal for this given system CPU and RAM. We are looking to support 100 active users at any given time. Is there a formula for scaling to number of engines relative to system specs; or of you can share any use case examples or example of topology with similar system specs would be greatly appreciated. TIA.
we have deployed Appian in onpremise. System logs navigation menu is missing. Updated the user as System Administrator. Still unable to access the logs. How to access log files in interface or using objects?
Post upgrade to Appian 22.1 process model is not showing write to data store and news feed smart services. Also getting invalid process message.
a!columnsLayout( columns: { a!columnLayout( contents: { if( isnull(local!exportDocId), /*This link field contains the link that starts the export*/ a!richTextDisplayField( labelPosition: "COLLAPSED", value: {a!richTextIcon( icon: "file-excel-o", color: "#6aa84f", size: "MEDIUM" )," ", a!richTextItem( text:"Export Customer Report to File", link:a!dynamicLink( label: "Export to Excel File", saveInto: { a!exportDataStoreEntityToExcel( entity: cons!FS_ORDER_ENTITY_POINTER, documentName: "Excel Export " & now(), saveInFolder: cons!FS_constant, onSuccess: a!save( local!exportDocId, fv!newDocument ), /*This displays an error if there is an issue executing the the save*/ onError: a!save( local!errorMessage, "Error Exporting File to Excel" ) ) } ), size: "STANDARD" ) } ), {} ), a!linkField( labelPosition: "COLLAPSED", links: a!dynamicLink( label: "<<<Back", value
When we try to do a cleanup older versions of an object which has say about 500-2000 versions in a document or an UI expression, it so happens that the object/document appears in environment but is unavailable to view details or refer the details back. This has been observed in Appian 22.1 and has occurred couple of times in our Dev environment. We have luckily a deployment on previous day and was able to recover the UI expression by importing the package from higher environment. However, for the document, we had a similar file with same uuid and ID and unable to delete it. Why does the deletion of versions delete the objects? Why do we see duplicates in terms of document that doesn't exist?
Is there a way to list expression rules which do not have a test case?
We're facing an issue where all URLs with a certain string contained within them are blocked no questions asked for security purposes. It just so happens that the URL of a particular record instance in PROD has the magic letters in order against quadrillions of chances, and it's now blocked so users can't access the record. Is there a way to change the URL that's generated for that particular record, such as changing the ID of the record? Should we try reimporting the record, or is it likely to wind up with the same ID?
In the past if an Appian object was currently open during an import then the import would fail. It seemed that this was resolved many versions ago, allowing the import to go through without issue. In the most recent version it seems to have come back, and imports now error out if an object is open. Has anybody else experienced this? This seems to be a step backwards in capability.
Hi, is there any recommended/possible way to get all nodes for some process model as a List of node names or something similar? I have a specific requirement where I have to track what is already done and what has to be done and display the 'journey' on an interface. Although I know there can be several possible paths of executing future nodes (Based on a logic stored in gateways), I need to create an interface which will track what is already done and what else has to be done. The main problem is how to fetch all process nodes dynamically, by some function or something similar. As process will change from time to time, keeping track of process nodes in some parallel db tables and mapping it to process state is not a solution I would like to implement. So If I have a following process model (this is just a simplified sketch, the real process model won't be linear and will have several possible flows): I want to be able to show a flow status grid on a separate interface, s
In what situations would any of you use an asynchronous sub-process as opposed to the start process smart service. Based on my understanding, because the smart service will better balance the execution engines without any other negative impacts - I don't see the scenario where I would ever use an asynchronous sub-process. Can someone please elaborate if there is something that I may be missing? Thank you!
Hi Team, I am working on building a performance test approach including platform baseline, benchmark for future growth and identifying when to scale infra and system capabilities. Can anyone share the 1. Performance test objectives at a platform level 2. Parameters to monitor at platform level 3. metrics for platform performance 4. Recommended resolutions (Eg. Adding more CPU) Thanks in advance
Hi All, I have tried to configure Both SAML authentication and login authentication for an url. Allowing some users authenticated using SAML and others using Login page. I have enabled SAML and provided IDP. In AuthenticationGroup, i have provided particular user group those can able to access the url through SAML Authentication. But others users are not redirected to appian login url page. How to restrict SAML authentication for some users? Kindly help.
Hi Folks. I am New to Appian installation in my local desktop. I have configured each of the step as mentioned in Appian Quick start guide for windows machine. When I am starting the engine getting this log continuously and it's not progressing ahead. Can anyone guide me is it due to temporary license that I need to get in ? If so how can I get it for my own POC work.
We are trying to build an audit report for overall sites usage at environment level. In the sites_usage.csv file we can see that all the page types(action, record type and reports) are getting audited but not interface type. Is it something Appian missed to audit in the sites_usage.csv or this is something which can not be achieved?
Aim is to implement Web APIs authenticated by an OAuth 2.0 client in appian. 1.I have created a sample WebAPI. 2. I have created a OAuth credentials from adminconsole. AdminConsole->Web API Authentication->OAuthclients2.0 If i try to access the webapi from browser it is accessible without authorisation. How to integrate this OAuth with my API. is there any attribute needs to be added in appian webapi.? Kindly help.
Hi All, There is requirement in our application, User account has to be created if user presented in the AD group even though user not login at all. this can be achieved via LDAP but we using SAML SSO. Is there any way or work around to achieve this? Thanks in Advance
Is there an alternative to eval() where I can evaluate a text input as part of the code? And also, why is it not a best practice to use the eval()?
while clicking in the infrastructure in the admin console, I am getting this error.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.