-
Recently active
Hi, I have a requirement. In a process model I am having processuuid as a process variable. Using this I have to start a process by using start process smart service. How can I achieve this?
We have a robotic subtask with a credential-type parameter, and when exporting and importing it into the target environment, I get the following error: The target environment has the same credential (same ID).
Hi Appian community, I know there were similar threads opened 3–4 years ago, and that Appian released a hotfix to address this issue. However, I’m still encountering the same problem in 25.2 with site page visibility. Even when I set the visibility rule to “Only show when” = false(), the page is still visible to System Administrator users. Does this rule always get overridden for System Administrators or other groups?
The workflow diagram in Case Management Studio collapses when a task points back to the previous task (2nd image). The workflow diagram is formed properly when tasks are linearly added one after the other (1st image). Did anyone observe this anomaly? How to resolve it?
I need the content of a windows file (the file is in csv format) in order to eventually send part of the content to an SQL Server database. I was able to upload the file into an appian document using Appian RPA. I'm also able to find the documentID of the uploaded document. I can't find a function/way of converting/loading the content of the document to a map/array. Is there another way of dealing with this? Please let me know, thank you.
Hi team, We are experiencing a minor issue with a generic interface that contains standard action buttons (Cancel, OK). This interface is called from two different Record Views: Record Summary 1 and Record Summary 2. Each summary has its own main interface which, in turn, calls our generic component. The Issue: Record Summary 1: Clicking the buttons works as expected. Record Summary 2: Clicking the buttons triggers an unexpected scroll to the top of the page. Observations: Interface Designer: When testing directly within the Summary interfaces, everything works correctly. Environment: The issue only occurs when accessing the views via a Record Link within a Site. Data Source Difference: There is one key difference between the Record Types: The working Record (Summary 1) points directly to a database table. The failing Record (Summary 2) points to a Data Store Entity (DSE). Can anyone helps?
There is a User Input Task in the process model that is assigned to a group. All users are receiving emails, but some members receive an email with only their email address in the ‘To’ field, while I received the same email with 10 members listed in the ‘To’ field. where to set this configuration
We are looking for connect our appian with on prem oracle via jdbc. We are trying to understand the error, but the suite/logs result in 403. There's another way for read it? We cannot have a troubleshooting without this kind of information.
We have two separate Appian applications, but deployment notification emails currently go to the same global recipient list. We need different groups to be notified based on which application is deployed. What is the recommended way to achieve this?
Agent Studio is a powerful new way to automate dynamic and open-ended tasks. By combining the power of generative AI with your data fabric and processes, you can build agents that reason through complex steps and take action automatically. Enroll in Agent Studio: Create Your First AI Agent to learn how to: Configure an AI agent with specific goals, instructions, and tools. Test and monitor agent reasoning and performance. Embed your agent into a process model using the Execute AI Agent smart service. This course features an optional hands-on exercise.Enroll here! If you have questions, please reach out to academyonline@appian.com.
Hi everyone, I’m facing an issue while trying to open an Integration Object related to SharePoint in Appian. Whenever I try to open the integration object, Appian shows the following error message: Il sistema ha rilevato un errore Codice HTTP: 500 APNX-1-4198-000 Errore durante la valutazione dell’espressione UI Errore di valutazione dell’espressione (evaluation ID = YGR65): com.appiancorp.connectedsystems.templateframework.functions.pipeline.proxyDecoratorPipeline.TemplateInvocationException com.appiancorp.suiteapi.common.exceptions.InvalidUserException Important details: This issue happens only with SharePoint Integration Objects Other integration objects open correctly The error occurs while opening the integration object, not during execution The connected system is already configured in other environments works just fine,only in test and dev environments give this error Has anyone encountered a similar issue with SharePoint integrations? I’d lik
Hi Appian Community, I am currently working on optimizing the performance of our processes in Appian and would like to monitor the memory usage of individual processes. Specifically, I am interested in obtaining the Appian Memory Units (AMUs) consumed by each process and including this information in our task reports. This way, we can query these reports using Process Analytics. Does anyone have experience or insights on how to capture and report the memory usage of processes in Appian? Any guidance on integrating this data into task reports and making it available for analytics would be greatly appreciated.
Hi All, I'm trying to learn Document Extraction using AI Skill and I'm facing an issue described below: Step 1: I have created an AI Skill object for Document Extraction and I have added only two fields in it. (Screenshot below). Step 2 : I have created a model to add this AI Skill(Ignored the XOR checks before reconciliation as it's just for learning purpose) Issue: The node stays active for a long time and I get an error "The number of retries to complete the execution of the smart service activity has been exceeded." The document is pdf and it has not exceeded the size limit. What is going wrong here?
I am exploring solution in Case Management Studio , Could you please help me understand whether task that is used in the Case management studio application will be alive until the parent process model completed 1) Suppose I have planned for 15 tasks in the cases management studio for a case , will the process model alive until those 15 tasks getting completed or it will be short lived once the particular task completed process model will be closed and new task will be generated 2) What are the limitations we have with case management studio application , Any help is greatly appreciated
Hello. I have a read-only grid that displays permissions data using a!recordData() as the data source. Currently, I can only capture the record IDs when users manually select rows in the grid using the selectionSaveInto parameter. My Goal:I want to automatically save all the record IDs returned by the a!recordData() query without requiring user selection and without using a!queryRecordType() in a separate expression or local variable. Current Implementation: a!gridField( label: "Permissions to Transfer:", instructions: "A temporary access group will be created to grant the selected permissions from the source employee to the destination employee.", helpTooltip: "Permissions that would generate risk combination or already belong to the Destination Employee have been hidden", labelPosition: "ABOVE", data: a!recordData( recordType: 'recordType!{57571bf8-20a7-4874-ac82-7f586277be58}GDA Permissao Acesso', filters
Normal http get integration. Getting below error and clearly query url is not created . It is working with bruno/postman. hardcoded the bearer authorisation token into the appian integration , getting the same error as below HTTP REQUET Note: The HTTP request did not include the following headers because they contained empty values: Authorization Accept X-IBM-Client-Id Content-Type Headers with empty values will be included in the request. Test again to see the results. RESULT error-result-label Connection timed out error-result-guidance The integration execution time exceeded the configured timeout Next Steps Retry the request later Set the timeout to a higher value
When using the Sync Records smart service in a process model targeting a service-backed record type, the node appears to only sync the first 100 records (and returns 100 as “Records Updated”) even when I pass more than 100 identifiers.1. Manual sync on the record type successfully syncs all records and respects batching.2. Scheduled sync also syncs all records.3. Smart service only ever syncs the first 100.My integration and sync expression pages correctly and return more than 100 records when called independently, and there is no documented 100-record limit in the Appian documentation.Has anyone else found this to be the case when it is stated to work with up to 1000 records (and does when used with non service-backed records)Thank you.
Hi all, I got this error in the log by seeing this I can identify this is a error in the process model general tab in localisation but when i checked i didn;t find any process model with this ID 13284 . Is there any chance this error could be somewhere else , any pointer will be helpful as only one user is facing this issue on prod. I know its a small fix in the code but I am not able to find out which object is giving this error Caused by: com.appiancorp.suiteapi.common.exceptions.AppianException: Contact your application administrator for help resolving this issue. Provide them with the following issue identifier: f09fa:1f895 (APNX-1-4533-000)   at com.appiancorp.sail.server.ServerExceptionTransformer.createLocalizedObfuscatedException(ServerExceptionTransformer.java:38)   ... 247 more 2026-01-12 10:22:57,171 [Appian Work Item - 19034860 - WorkID 601 - execution02 - process 145291393 - model 13284 : UnattendedJavaActivityRequest] ERROR com.appiancor
I have a .txt file and i need encrypt to share to other system, I see the functionality to encrypt PDF and EXCEL but to encrypt .txt file dont.
Hi Everyone, I have requirement to retrieve resulting CDT list by filtering nested CDT list containing key-value Tier:1 in nested CDT. This is CDT list local: list { { ReportFacilityId:30803, FacilityId:3551, FormInstanceId:4271964, FacilityName:"Test 1", IsSectionLarger:false, FacilityMode: { { A15LinkModeId:17394, ModeId:4, ToS: 1, Tier:1 }, { A15LinkModeId:17394, ModeId:4, ToS: 3, Tier:2 } } }, { ReportFacilityId:30804,
Is there a list of all available Appain Example Images somewhere(example: a!EXAMPLE_RECEPTIONIST_IMAGE())? I find them easy to use to quickly put together a POC.
We are building an Appian Portal interface that queries and displays data from a record type (MEPub_PublicCases) using a!queryRecordType() and renders the results in a custom a!gridField(). The interface behaves as expected when previewed in Appian Designer: Records are returned All requested record fields display correctly in the grid Paging and sorting work However, when accessing the same interface via the Portal Site URL, the grid does not display any data, or the data fails to load entirely. This occurs even when: No filters are applied (initial load querying all records) fetchTotalCount: true is used Required fields are explicitly listed in the fields: parameter The record type security includes Viewer/Admin access for the relevant service/integration account Expected Behavior When accessed via the Portal URL: The portal page should successfully query the record type Records should display in the grid exactly as they do in Appian Designer Paging and sorti
I am working on Excel classification using AI Document Center .After the classification process completes, I m not getting the confidence score in Pv and database. how to resolve it?
We have a process model that is the same in our dev and test environments (compare and deploy shows Not Changed). In this user input task, the interface is also the same between dev and test environments. However, in our dev environment, the interface shows up normally in this user input task, but in our test environment, it shows up as this. Even if I try to search for the interface myself so I can relink it to this node, it still shows this error. On the UI, instead of showing the most updated version of the interface, it shows an old version from several months back. If I check version changes to the process model in the test environment, it still says there is an interface in this user input task. If I check process model versions from several months back, I still see this error on the user input task, even though I know several months back when I was testing this process, everything looked fine. If I check the UI in dev, everything looks normal, so dev is functioning fine, and co
Do we require this AI Document Center - Generated Objects application to add the model to the Appian Process?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.