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DRAFT KB-XXXX Unblock Health Check stuck at 'Analyze Data'

Symptoms

If the Health Check is stuck on the 'Analyze Data' stage, there are no errors printed in any logs or additional symptoms. Users typically see this happen on the first execution.

Cause

The Appian Health Check hangs during the "Analyze Data" stage because there is no timeout specified for the HTTP connection to Appian Forum.

  • This issue has been addressed via AN-148308 in Appian 19.4.70.0 Hotfix Package C.

Action

To prevent the Appian Health Check being stuck:

  • Apply the latest hotfix to your Appian installation.

To unblock the Appian Health Check;

  1. Connect to the Appian Primary Database
  2. Run: SELECT * FROM healthcheck;
  3. For any rows that have a fields of 'status=RUNNING' and 'heartbeat=null', note down the value of 'id'
  4. With the identified 'id' in Step 3, run: UPDATE healthcheck set status='FAILED',status_constraint=<ID OF HANGING RUN> where id=<ID OF HANGING RUN>;

Affected Versions

  • This article applies to Appian 19.4.70.0 and earlier. 

Last Reviewed: March 2020