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KB-XXXX System emails/process emails are no longer being sent with a "Connection refused" error

Symptoms

  • System emails for account creation are not sent.
  • System emails for resetting a password are not sent.
  • Process models with Send Email nodes are paused.
  • The application server log will contain the following errors:
    ERROR com.appiancorp.ra.workpoller.WorkItemListener - The following exception occurred while attempting to complete work item [(WorkId: 14, WorkType: [AbstractMailRequest: from=null, to=<Email>, subject=<Subject>], Response: null, ServerName: NotificationsEmail)] - Exception:
    javax.resource.spi.work.WorkCompletedException: com.appiancorp.process.engine.EmailBodyException: Email body failed to render
    …
    Caused by: javax.ejb.EJBException: com.appiancorp.process.engine.EmailBodyException: Email body failed to render
    …
    Caused by: javax.net.ConnectException: Connection Refused

Cause

The underlying cause of the issue can vary, but is usually associated with web server or application server configurations, or networking configurations.

The application server exposes and invokes an HTTP endpoint in order to generate the email body. When the application server is unable to invoke the endpoint (due to a configuration or networking issue), it will be unable to generate email bodies, and thus unable to send emails.

Action

  1. Confirm that <APPIAN_HOME>/conf/custom.properties has the correct and expected configurations for MAIL_SERVER_AND_PORT and MAIL_SCHEME. See here for more details.
  2. Confirm that the standalone.xml (JBoss) and Context.xml (Tomcat) configurations have declared the appropriate http listener in order to accept http connections.
  3. Use a networking utility to confirm connectivity to the application server on the expected port.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: January 2020