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KB-2052 System emails/process emails are no longer being sent with a "Connection refused" error

Symptoms

  • System emails for account creation are not sent.
  • System emails for resetting a password are not sent.
  • Process models with Send Email nodes are paused.
  • The application server log will contain the following errors:
    ERROR com.appiancorp.ra.workpoller.WorkItemListener - The following exception occurred while attempting to complete work item [(WorkId: 14, WorkType: [AbstractMailRequest: from=null, to=<Email>, subject=<Subject>], Response: null, ServerName: NotificationsEmail)] - Exception:
    javax.resource.spi.work.WorkCompletedException: com.appiancorp.process.engine.EmailBodyException: Email body failed to render
    …
    Caused by: javax.ejb.EJBException: com.appiancorp.process.engine.EmailBodyException: Email body failed to render
    …
    Caused by: javax.net.ConnectException: Connection Refused

Cause

This issue occurs when the application server is unable to connect to the HTTP endpoint to render the email body. This can occur when there is a mis-configuration in custom.properties or if the HTTP listener has been removed from the application server configuration.

Action

  1. Confirm that <APPIAN_HOME>/conf/custom.properties has the correct and expected configurations for MAIL_SERVER_AND_PORT and MAIL_SCHEME. See the documentation for more details.
  2. Confirm that the standalone.xml (JBoss) and context.xml (Tomcat) configurations have declared the appropriate HTTP listener in order to accept HTTP connections.
  3. Use a networking utility to confirm connectivity to the configured HTTP endpoint.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: January 2020