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Unable to initiate a new health check

Symptoms

The user is unable to initiate a new health check even though there are no running health checks in the system.

If using the 'Start Appian Health Check' action with the application, the following error will be seen:

If performing manual collection via the servlet, the following is displayed:

Cause

When the Health Check runs, it creates a file in the system called health-check-status.json. If the Health Check is abruptly cancelled before it completes, the health-check-status.json file will identify the status as 'RUNNING'. The user will be unable to initiate a new Health Check because the system believes there is already one running. 

Action

  1. Navigate to /design and click on the 'Objects' tab
  2. In the search bar, search for "health-check-status". Click on the file and it will open /designer. Click on health-check-status.json. When you click on it, the file will download to your computer.
  3. Open the file in an editor and if it indicates the status as 'RUNNING', proceed with the steps below.
  4. In /designer, select and delete the health-check-status.json file