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DRAFT KB-XXXX Cannot run program "jps" error when starting Service Manager

Symptoms

When executing a Service Manager script in the <APPIAN_HOME>/services/bin directory, the following error is returned:

Exception thrown while attempting to retrieve process info for java process with main Class name QuorumPeerMain. java.io.IOException: Cannot run program "jps": error=2, No such file or directory
...
Caused by: java.io.IOException: error=2, No such file or directory

Cause

This error is returned when the JAVA_HOME path is set to JRE, rather than JDK. As per the Appian system requirements, JDK is the supported option.

To check the JAVA_HOME variable:

  • In Windows, right click My Computer and select Properties. On the Advanced tab, select Environment Variables, and edit JAVA_HOME to view the JDK path.
  • In Linux, type echo $JAVA_HOME in a terminal to view the Java path.

Action

To resolve the issue, change the JAVA_HOME path to point to the JDK:

  • In Windows, right click My Computer and select Properties. On the Advanced tab, select Environment Variables, and edit JAVA_HOME to point to the correct JDK path.
  • In Linux, one way would be to run the following commands as the root user:
    1. export JAVA_HOME=<PATH_TO_JDK>
    2. export PATH=${PATH}:{JAVA_HOME}/bin

Affected Versions

This article applies to Appian 17.3 and later