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DRAFT KB-XXXX Basic users are unable to see tempo/profile/settings

Symptoms

Basic users are unable to see tempo. The content of the page looks like the following:

In the application server log, this error is thrown:

10:22:01,330 INFO [stdout] (ajp-/0.0.0.0:8009-8) Caused by: PrivilegeException[null=>null]: User Does Not Have Rights to Perform this Operation 
10:22:01,330 INFO [stdout] (ajp-/0.0.0.0:8009-8) at sun.reflect.GeneratedConstructorAccessor725.newInstance(Unknown Source) 
10:22:01,330 INFO [stdout] (ajp-/0.0.0.0:8009-8) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) 
10:22:01,331 INFO [stdout] (ajp-/0.0.0.0:8009-8) at java.lang.reflect.Constructor.newInstance(Constructor.java:423) 
10:22:01,331 INFO [stdout] (ajp-/0.0.0.0:8009-8) at com.appiancorp.kougar.mapper.Mapper.prepareThrowable(Mapper.java:157) 
10:22:01,331 INFO [stdout] (ajp-/0.0.0.0:8009-8) at com.appiancorp.kougar.mapper.Mapper.request(Mapper.java:95)

On click on Profile, a pop-up appears with the following message:

An error was encountered while processing your request. Please try again.

When trying to see the settings page, this error appears:

Cause

The issue happens when the User pictures folder is missing from the Default Community or when the basic users don't have viewer rights on this folder.

 

Action

First, verify that the User pictures folder is present in the Default Community. This KB article details how to check the presence of the folder and how to retrieve it if the folder is missing.

Then, verify the rights on the Users pictures folder:

For Appian version 17.4 and later

  1. Log in as an administrator
  2. Go to Runtime Data.
  3. Select Documents and expend the Communities list.
  4. Click on Default Community and then System Knowledge Center.
  5. Select the checkbox at the left of the User Pictures folder and then click on Security.
  6. Check the box "Inherit security from parent.".

For Appian version 18.1 and earlier

  1. Log in as an administrator.
  2. Go to Appian Designer.
  3. On the left search bar, search for: User Covers.
  4. Click on the User Covers checkbox and then on Security.
  5. Verify that Default (All Other Users) or the All User group have the Viewer permission level.

 

 

Affected Versions

  • This article applies to all versions of Appian.