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DRAFT KB-XXXX News posts missing in Tempo

Symptoms

News posts before a specific date have disappeared from Tempo.

Cause

News posts are stored in the Appian primary data source in the 'tp_feed_entry' table. These posts are indexed for quick retrieval. If these indices become corrupted, indexing must restart, which causes only new entries to be stored and displayed in Tempo. The following sections explain how the posts are indexed based on the Appian version:

Appian 17.1

  • These news posts are indexed purely by the Apache Lucene software. The indices are stored in the <APPIAN_HOME>\_admin\search-local\index-primary directory.

Appian 17.2 and Later

  • These news posts are not purely indexed by Appian Lucene. Starting with Appian 17.2, the search server began to assume the role of indexing. This is why the <APPIAN_HOME>\_admin\search-local directory in 17.2 contains both the index-primary and search-server folders.
  • Starting with Appian 17.3, these news posts are purely indexed by the search server. The index files are stored in the <APPIAN_HOME>\_admin\search-local\search-server\data\appian-search-cluster\nodes\0\indices directory.
  • If search server experiences an issue (i.e. crashes due to network issue or runs out of disk space), the indices may become corrupted.
  • The root cause of the search server crash can be determined by examining the logs located at <APPIAN_HOME>\logs\search-server.

Action

  1. Review the <JBOSS_HOME>\standalone\deployments\*-ds.xml and confirm that the environment is pointing to the correct primary data source.
  2. Once confirmed, connect to the primary data source and run the following query: SELECT * FROM tp_feed_entry ORDER BY id ASC;
  3. Inspect the content returned by the query. If the content contains old news posts (that are currently missing from Tempo), proceed to the following steps based on the corresponding Appian version (Note: please perform these steps outside of business hours to avoid any potential performance impact):

Appian 17.1

  1. In the <APPIAN_HOME>\_admin\search-local\index-primary directory, open the lastsync.properties file.
  2. Delete the contents of the lastsync.properties file and save it.
  3. Wait a few minutes and check that the lastsync.properties file has been repopulated with a new timestamp and that the news post entries are now showing up.

If the above procedure does not resolve the issue, proceed with the following steps:

  1. Stop Appian.
  2. Delete the the <APPIAN_HOME>\_admin\search-local\index-primary directory.
  3. Start Appian.
  4. Check that the lastsync.properties file has been repopulated with a new timestamp and that the news post entries are now showing up.

Appian 17.2 and Beyond

  1. Stop the application server and search server.
  2. Delete the the <APPIAN_HOME>\_admin\search-local directory.
  3. Start the application server and search server.

Note: Resetting the search server indices can resolve a number of other issues. See KB-1082 for more symptoms regarding issues related to the search server indices.

Affected Versions

This article applies to Appian 17.1 and later.

Last Reviewed: June 2018