You are currently reviewing an older revision of this page.

DRAFT KB-XXXX Plugin fails after upgrade to 18.3 with "Unable to find [jdbc]" error in application server log

Symptoms

A plugin that was previously working fails after an upgrade to Appian 18.3, and the following error appears in the Tomcat log:

javax.naming.NameNotFoundException: Name [jdbc/Appian] is not bound in this Context. Unable to find [jdbc].

Cause

The plugin is configured to connect to the database using a format that is no longer accepted by Tomcat. For example:

DATASOURCE_CONTEXT=java:/jdbc/Appian

Tomcat does not accept the 'java:' prefix in datasource context property.

Action

  1. Unzip the plugin JAR file. 
  2. Identify where the datasource context is defined within the plugin by searching the plugin files for the context string "java:/jdbc/<DB_Name>". This is often defined in a properties file.
  3. Remove the 'java:/' prefix. This change can be made from within archival software
  4. Redeploy the plugin. 

Affected Versions

This article applies to Appian 18.3  and later.

Last Reviewed: October 2018