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DRAFT KB-XXXX- User are unable to receive email from Appian.

Symptoms

User are unable to receive emails from Appian and the following errors are noticed in the application server logs after enabling additional email loggers: 

17:42:44,364 INFO  [stdout] (Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest) 2018-08-28 17:42:44,364 [Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest] DEBUG com.appiancorp.process.runtime.activities.SendEmailActivity - fromKey=processModel

17:42:44,365 INFO  [stdout] (Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest) 2018-08-28 17:42:44,364 [Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest] DEBUG com.appiancorp.process.runtime.activities.SendEmailActivity - Sender Option for [fromKey]: null

17:42:44,382 INFO  [stdout] (Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest) 2018-08-28 17:42:44,382 [Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest] DEBUG com.appiancorp.process.runtime.activities.SendEmailActivity - Not setting 'Sender' header

For JBoss, sever.log is located in the <JBOSS_HOME>/standalone/log directory. For Tomcat, tomcat-stdOut.log file is located in the <APPIAN_HOME>/log directory.  

More information on how to enable additional email loggers can be found here.

Cause

This issue is caused when the Email service is turned off from the Admin console or if the custom.properties file located under <APPIAN_HOME>/conf directory is missing proper configurations as mentioned in the documentation here

Action

1. Ensure that the Appian is allowed to send emails via selecting the "Allow Appian to send email" tab on https://<Site-name>/suite/admin/page/email. 

2. In order to validate your configurations ensure that you are able to perform all the mail server testing steps mentioned here.  

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: October 2018