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System emails/process emails are no longer being sent with an "Email body failed to render... Connection refused" error

Symptoms

When attempting to reset a password or use the send E-Mail smart service, the logs will show the contents of the email, but the user will never receive the message.

The application server log will show the following error:

Exception:
javax.resource.spi.work.WorkCompletedException: com.appiancorp.process.engine.EmailBodyException: Email body failed to render: MailBody{<FILE_PATH>}
...
Caused by: javax.ejb.EJBException: com.appiancorp.process.engine.EmailBodyException: Email body failed to render: MailBody{<FILE_PATH>}
...
Caused by: com.appiancorp.process.engine.EmailBodyException: Email body failed to render: MailBody{<FILE_PATH>}
...
Caused by: java.net.ConnectException: Connection refused (Connection refused)

 


Cause

 

This error will be seen when an Appian environment is configured with a web server to use HTTPS/SSL scheme. All email requests in Appian are routed through the server specified in the conf.suite.SERVER_AND_PORT property unless values are given for conf.suite.MAIL_SCHEME and conf.suite.MAIL_SERVER_AND_PORT, all found in custom.properties located in <APPIAN_HOME>/ear/suite.ear/conf or for version 18.2 and higher, <APPIAN_HOME>/conf.

The above symptoms are a result of Appian trying to route email requests from the application server to the web server. As the web server has been configured with SSL, the application server needs to use SSL for creating the email body. By default, the application server does not have the necessary certificates to create this connection and thus it fails to create the email body.

 

 

Action

 

 

Workaround

 

 

Affected Versions:

 

 

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