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DRAFT KB-XXXX "Invalid Security Token" reported in service manager log

Symptoms

In the service_manager.log file located in <APPIAN_HOME>/logs/, the following warning is present:

com.appian.komodo.gateway.handler.codec.SecurityTokenDecoder - Invalid Security Token.

Cause

There are two potential causes that could result in this warning message:

  1. This warning can appear when the security token has been modified or deleted. In particular, it happens when the security token has been changed after starting Service Manager, causing the engines to refuse the connection with the application server. This cause will be accompanied by the application server failing to start.
  2. This warning can appear when a port scanner, or some other process connects to the Appian engine ports. The warning appears because the scanner or process connecting to the port does not have or does not send a valid security token at the beginning of its connection. 

Note: For the 2nd cause listed above, the invalid security token warning message can be disregarded. The following documentation provides additional details about the security token.

Action

To address issues with the security token being modified or deleted, follow the procedures outlined in KB-1823 to either copy the security token from a backup directory, or to generate a new security token.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: January 2019