You are currently reviewing an older revision of this page.

DRAFT KB-XXXX Connected systems fail to load with InsufficientNameUniquenessException found in the application server log following an upgrade

This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Symptoms

Following an upgrade of Appian, select Connected System objects fail to load with the below error message:

In the application server log, the below error message will be printed:

YYYY-MM-DD HH:MM:SS [localhost-startStop-1] ERROR com.appiancorp.connectedsystems.http.migration.configobject.MigratePersistedConnectedSystems - Error persisting, migration will be skipped for this connected system: ... com.appiancorp.suiteapi.content.exceptions.InsufficientNameUniquenessException: Name is insufficiently unique

Cause

This behavior occurs when an Appian Application has the same name as a Connected System object. This issue has been addressed via AN-145648 in the following hotfixes/versions:

If you require a hotfix for Appian 17.4 - 18.1, please open a support case with Appian Support.

Action

Apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Workaround

There are two workarounds that can resolve this issue:

1) Recreate Connected Systems

  1. Create a new Connected System object with the same credentials.
  2. Update your integrations to use this new Connected System object.
  3. Remove the old Connected System object you are replacing.

2) Resolve Naming Clash and Re-run EncryptionMigration

  1. Find the Application that has a matching name to a Connected Systems object. Enter the Application Context for that App (i.e. click on the application in /suite/design/)
  2. In the top right, click the gear and select "Application Properties."
  3. Rename the Application and click "Save Changes"

Cloud

Open a case with Appian Support and note to the case description that you are experiencing behavior in line with this article. Ensure to confirm on the support case that you have performed the above steps for the second workaround option.

On-Premise

  1. Add the following line to custom.properties file in <APPIAN_HOME>/conf:
    conf.suite.RERUN_CS_ENCRYPTION_MIGRATION=true
  2. Start the application server.
  3. Once the environment is accessible again, you can remove the added line from the custom.properties file.

Affected Versions

This article applies to Appian 17.4 and later.

Last Reviewed: December 2019