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DRAFT KB-XXXXX The file null could not be uploaded

Symptoms

When attempting to upload a file, user will see a box that says "The file null could not be uploaded. Please try uploading it again."

 

The following error will also appear in the application server log:

com.appiancorp.security.auth.activity.UserActivityFilter - Could not record user activity: XXXXXXXXX, authDetails=null -- java.lang.NullPointerException
ERROR com.appiancorp.content.ExtendedContentServiceJavaImpl - Couldn't create the deactivated files with names: {XXXXXXX}
com.appiancorp.suiteapi.common.exceptions.StorageLimitException: No more space available 

 

Cause

User has reached their file upload limit. While user upload limits were deprecated in 17.3, the content engine is still enforcing the limit. This will prevent any users who have reached their limit from uploading files.

 

Action

Version 18.4 and earlier: Upgrade to version 19.1+ and apply the latest hotfix

Version 19.1 and later: Apply the latest hotfix

 

Affected Versions

This article applies to Appian 17.3 and later

Last Reviewed: December 2019