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DRAFT [SP-2343] Emails fail to send to Office 365 with "Failed to process message due to a permanent exception with message" error

Symptoms

Office 365 configured as the email server for an Appian cloud site fails to send emails. The following error can be seen in the application server log

javax.resource.spi.work.WorkCompletedException: com.appiancorp.process.engine.EmailSendException: Could not send email [from=<FROM_DDRESS>, to=<TO_ADDRESS>, subject=<SUBJECT> ... Caused by: com.appiancorp.process.engine.EmailSendException: Could not send email [from=<FROM_ADDRESS>, to=<TO_ADDRESS>, subject=<SUBJECT> ... Caused by: com.sun.mail.smtp.SMTPSendFailedException: 554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message

Cause

Office 365 is blocking emails with the address specified in the 'from' field of the above error message. One possible reason This is often the Appian Cloud site's system email address.

Action

There are two possible actions that can resolve the issue;

  • Update the Office 365 settings to allow sending from the blocked email address.
  • Change the 'from' email address to an address allowed by the Office 365 settings.

Affected Versions

This article applies to all versions on Appian Cloud

Last Reviewed: March 2020