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[SP-3981] DRAFT KB-XXXX "Does not exist: Process" Error thrown in application server log, or when accessing a process instance

Symptoms

When accessing a process instance via the Process Monitoring tab, the below error is thrown:

Load Error
Errors
This process diagram could not be opened due to the following errors.
Does not exist: Process

A similar error is printed in the application server stdOut log:

ERROR com.appiancorp.expr.server.reaction.smartservicebridge.SmartServiceBridgeReaction - Exception occurred during activation of ReactionFunction {key='sys.smartService.start-process-2', class='com.appiancorp.expr.server.reaction.smartservicebridge.PluginSmartServiceBridgeReaction'}
...
Caused by: com.appiancorp.suiteapi.process.exceptions.InvalidProcessException: Does not exist: Process

Cause

The process instance has been archived or deleted

Action

  1. If the process has been archived, follow steps outlined in KB-1186 to unarchive the process instance.
  2. Adjust archival/deletion thresholds in the Data Mangement tab to allow future process instances to be maintained for the desired amount of time after completion. Note increasing the length of time Process Instances are maintained before archival/deletion can increase system memory and disk resource utilization for your Appian environment.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: April 2020