KB-2150 Process Analytics engine issues from mismatched hostname
Symptoms
The below error is found in the db_PA* logs located in the <APPIAN_HOME>/logs directory:
2019-11-27 03:33:15 [PA00XX1] {paXXX.kdb ,XXXXXX} (Default) ERROR .a.p.ANLYZE.i "This engine is recognized as host [localhost.localdomain] port [XXXX] for local development on a single machine (do not use in production, as this matches all machines), but this did not match appian-topology.xml's host [<HOSTNAME>] port [XXXX]."
The symptoms may also include:
- Users are unable to see any rows in process reports.
a!queryProcessAnalytics()returns an empty result.- The ResetAnalytics script fails to run.
Cause
The host name in the appian_topology.xml file does not match the host name in the server hosts file.
Action
Set the hostname in the topology file to match the hostname retrieved by running <APPIAN_HOME>/_admin/_scripts/licinfo.sh (.bat).
Note: The host name is case-sensitive.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: September 2020
